aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2024-07-22 17:45:26 -0500
committerjgart <jgart@dismail.de>2024-07-25 17:26:09 -0500
commitefc26826400762207cde9f23802cfe75a737963c (patch)
treef581a1ec3a706b8b79cba0ab614ac8dbaa1307bd /gnu
parent119d658d7543c84624719a364fa980cc80c2095d (diff)
downloadguix-efc26826400762207cde9f23802cfe75a737963c.tar
guix-efc26826400762207cde9f23802cfe75a737963c.tar.gz
gnu: python-waitress: Update to 3.0.0.
* gnu/packages/python-xyz.scm (python-waitress): Update to 3.0.0. [build-system]: Use pyproject-build-system. [arguments]: Disable failing test. * gnu/packages/patches/python-waitress-fix-tests.patch: Delete no longer needed patch. * gnu/local.mk: Delete patch line. Change-Id: I5397649e30098627de8c24f6afa2b74413d3446a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/python-waitress-fix-tests.patch29
-rw-r--r--gnu/packages/python-xyz.scm11
3 files changed, 7 insertions, 34 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index df4e32add7..fac7b5973b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1989,7 +1989,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-unittest2-remove-argparse.patch \
%D%/packages/patches/python-vega-datasets-remove-la-riots-code.patch \
%D%/packages/patches/python-versioneer-guix-support.patch \
- %D%/packages/patches/python-waitress-fix-tests.patch \
%D%/packages/patches/python-werkzeug-tests.patch \
%D%/packages/patches/python-xmp-toolkit-add-missing-error-codes.patch \
%D%/packages/patches/python-zeep-Fix-pytest_httpx-test-cases.patch \
diff --git a/gnu/packages/patches/python-waitress-fix-tests.patch b/gnu/packages/patches/python-waitress-fix-tests.patch
deleted file mode 100644
index 110492a604..0000000000
--- a/gnu/packages/patches/python-waitress-fix-tests.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Skip test that requires getaddrinfo(), which is not available in the build
-environment. This package uses a regexp for finding tests (see runner.py),
-so using @unittest.skip does not work.
-
---- a/waitress/tests/test_adjustments.py
-+++ b/waitress/tests/test_adjustments.py
-@@ -185,22 +185,6 @@
- def test_bad_port(self):
- self.assertRaises(ValueError, self._makeOne, listen='127.0.0.1:test')
-
-- def test_service_port(self):
-- if WIN and PY2: # pragma: no cover
-- # On Windows and Python 2 this is broken, so we raise a ValueError
-- self.assertRaises(
-- ValueError,
-- self._makeOne,
-- listen='127.0.0.1:http',
-- )
-- return
--
-- inst = self._makeOne(listen='127.0.0.1:http 0.0.0.0:https')
--
-- bind_pairs = [sockaddr[:2] for (_, _, _, sockaddr) in inst.listen]
--
-- self.assertEqual(bind_pairs, [('127.0.0.1', 80), ('0.0.0.0', 443)])
--
- def test_dont_mix_host_port_listen(self):
- self.assertRaises(
- ValueError,
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fcf01f3d04..d1b3882cd5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19254,16 +19254,19 @@ templates into Python modules.")
(define-public python-waitress
(package
(name "python-waitress")
- (version "1.1.0")
+ (version "3.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "waitress" version))
- (patches (search-patches "python-waitress-fix-tests.patch"))
(sha256
(base32
- "1a85gyji0kajc3p0s1pwwfm06w4wfxjkvvl4rnrz3h164kbd6g6k"))))
- (build-system python-build-system)
+ "18dq4bibsv6cfhv6a3b16w2xwycxqkkiwbb0vpcwsd21n1ws8p80"))))
+ (build-system pyproject-build-system)
+ (arguments
+ ;; https://github.com/Pylons/waitress/issues/443
+ (list #:test-flags #~(list "-k" "not test_service_port")))
+ (native-inputs (list python-pytest python-pytest-cov))
(home-page "https://github.com/Pylons/waitress")
(synopsis "Waitress WSGI server")
(description "Waitress is meant to be a production-quality pure-Python WSGI