aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-18 14:43:06 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:00:09 +0000
commitefa604c17145faf23b7d5cbbda6bc2f694626961 (patch)
tree8ef092514158cd219fcba758b191452e5d93c1de /gnu
parent2160edac9339e792069831489449196943c6ce6f (diff)
downloadguix-efa604c17145faf23b7d5cbbda6bc2f694626961.tar
guix-efa604c17145faf23b7d5cbbda6bc2f694626961.tar.gz
gnu: python-pydevd: Use git tag.
* gnu/packages/python-xyz.scm (python-pydevd): [source]: Compile tag from package version. [arguments]<#:test-flags>: Adapt value. Change-Id: I55cc8129fb78f0ee54519f45b31746a54881d84e Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 7 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3b1db2bdf7..098712f66d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17614,17 +17614,17 @@ developed separately, both serve the same purpose: provide Python bindings for
libmagic.")))
(define-public python-pydevd
- (let ((revision "1")
- (commit "d0f81de46ec51687ac24ae9598eb2615010a4b44"))
(package
(name "python-pydevd")
- (version (git-version "3.2.3" revision commit))
+ (version "3.2.3")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/fabioz/PyDev.Debugger")
- (commit commit)))
+ (commit (string-append
+ "pydev_debugger_"
+ (string-join (string-split version #\.) "_")))))
(modules '((guix build utils)))
(snippet '(begin
;; Delete pre-built binaries.
@@ -17646,18 +17646,14 @@ libmagic.")))
;; Python 3.10:
;; <https://github.com/fabioz/PyDev.Debugger/issues/222>.
"not test_set_pydevd_break_01 "
- ;; This one fails for unknown reasons.
- "and not test_completion_sockets_and_messages "
;; the GUI event loop requires an X server.
"and not test_gui_event_loop_custom "
;; This test validates that 'pydevd' is not in the
;; exception message, but it is due to being part
;; of the build file name present in the message.
"and not test_evaluate_exception_trace "
- ;; These fail on systems with YAMA LSM’s ptrace
- ;; scope > 0. Upstream issue:
- ;; https://github.com/fabioz/PyDev.Debugger/issues/218
- "and not test_attach_to_pid"))
+ ;; This test fail with TimeoutError, no message on stderr.
+ "and not test_soft_terminate "))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'fix-tests
@@ -17725,7 +17721,7 @@ libmagic.")))
(synopsis "Python debugger")
(description "PyDev.Debugger is a capable Python debugger used in PyDev
and other @acronym{IDEs, Integrated Development Environments}.")
- (license license:epl1.0))))
+ (license license:epl1.0)))
(define-public python-debugpy
(package