aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-19 07:31:54 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-11-01 20:44:29 +0100
commitec7d68bcefd70679c5b97502d394afbca26a785b (patch)
treec649533aaf3acc363be2dd0f0aec58cc712351df /gnu
parent95fec09d4ba640bcb3e6f116c239c0a86551cd5a (diff)
downloadguix-ec7d68bcefd70679c5b97502d394afbca26a785b.tar
guix-ec7d68bcefd70679c5b97502d394afbca26a785b.tar.gz
gnu: emacs-eweouz: Build autoloads before installing them.
* gnu/packages/emacs-xyz.scm (emacs-eweouz)[#:phases]: Move ‘emacs-make-autoloads’ after ‘enter-lisp-dir’.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d0e9d1b226..ba08dcd20f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3756,6 +3756,8 @@ defined in RFC 2425 and RFC 2426 to/from The Insidious Big Brother Database
(emacs-substitute-sexps "eweouz.el"
("eweouz-helper-dirs"
`(list ,(string-append #$output "/libexec/eweouz"))))))
+ (add-after 'enter-lisp-dir 'emacs-make-autoloads
+ (assoc-ref emacs:%standard-phases 'make-autoloads))
(add-after 'emacs-patch-variables 'emacs-expand-load-path
(assoc-ref emacs:%standard-phases 'expand-load-path))
(add-after 'emacs-expand-load-path 'emacs-add-install-to-native-load-path
@@ -3763,9 +3765,7 @@ defined in RFC 2425 and RFC 2426 to/from The Insidious Big Brother Database
(add-after 'emacs-add-install-to-native-load-path 'emacs-install
(assoc-ref emacs:%standard-phases 'install))
(add-after 'emacs-install 'emacs-build
- (assoc-ref emacs:%standard-phases 'build))
- (add-after 'emacs-install 'emacs-make-autoloads
- (assoc-ref emacs:%standard-phases 'make-autoloads)))))
+ (assoc-ref emacs:%standard-phases 'build)))))
(native-inputs
(list autoconf
automake