aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-11-20 20:04:26 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:05:28 +0200
commite612f7ad02c2ca6612885a9d1961b48fc9e99979 (patch)
tree34537fd4f7ff630018e348c6658748d675d9e17a /gnu
parentaf134335b338a333767c928bb33a150f565658f1 (diff)
downloadguix-e612f7ad02c2ca6612885a9d1961b48fc9e99979.tar
guix-e612f7ad02c2ca6612885a9d1961b48fc9e99979.tar.gz
gnu: Add rust-android-log-sys-0.3.
* gnu/packages/crates-io.scm (rust-android-log-sys-0.3): New variable. (rust-android-log-sys-0.2): Inherit from rust-android-log-sys-0.3. Change-Id: If197a2b2a804abc3c55845f516ed0989b20d906a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 19 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index cdbf4a9afc..b54d8a4588 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1615,24 +1615,38 @@ with @code{NativeActivity} or @code{GameActivity}.")
(description "This package provides the glue for the Android JNI.")
(license license:expat)))
-(define-public rust-android-log-sys-0.2
+(define-public rust-android-log-sys-0.3
(package
(name "rust-android-log-sys")
- (version "0.2.0")
+ (version "0.3.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "android_log-sys" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0bhhs1cgzp9vzjvkn2q31ppc7w4am5s273hkvl5iac5475kmp5l5"))))
- (arguments `(#:skip-build? #true)) ;XXX: Android only
+ (base32 "0dwrvwkx2xxqys6nrhfavbbqfx2rs61nq8akrlnqkfbapxb81k2y"))))
(build-system cargo-build-system)
- (home-page "https://github.com/nercury/android_log-sys-rs")
+ (arguments `(#:skip-build? #true)) ;XXX: Android only
+ (home-page "https://github.com/rust-mobile/android_log-sys-rs")
(synopsis "FFI bindings to Android log Library")
(description "This package provides FFI bindings to Android log Library.")
(license (list license:expat license:asl2.0))))
+(define-public rust-android-log-sys-0.2
+ (package
+ (inherit rust-android-log-sys-0.3)
+ (name "rust-android-log-sys")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "android_log-sys" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0bhhs1cgzp9vzjvkn2q31ppc7w4am5s273hkvl5iac5475kmp5l5"))))
+ (arguments `(#:skip-build? #true)))) ;XXX: Android only
+
(define-public rust-android-log-sys-0.1
(package
(inherit rust-android-log-sys-0.2)