aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-01-26 00:43:03 +0100
committerAndreas Enge <andreas@enge.fr>2013-01-26 00:43:03 +0100
commite5c0701f9c77afdce0e4c8ae502ad93177a81b88 (patch)
treeab1e01e15b7072a0f568552c14947221e55d960b /gnu
parentcc957c3c7461fbad38978b7c8b4d76e3c0aca80a (diff)
downloadguix-e5c0701f9c77afdce0e4c8ae502ad93177a81b88.tar
guix-e5c0701f9c77afdce0e4c8ae502ad93177a81b88.tar.gz
gnu: Add TECkit.
* gnu/packages/freetype.scm (teckit): New variable. * gnu/packages/patches/teckit-cstdio.patch: New file. * Makefile.am (dist_patch_DATA): Add patch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/freetype.scm40
-rw-r--r--gnu/packages/patches/teckit-cstdio.patch10
2 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/freetype.scm b/gnu/packages/freetype.scm
index 4800c43fd9..881e655508 100644
--- a/gnu/packages/freetype.scm
+++ b/gnu/packages/freetype.scm
@@ -18,6 +18,7 @@
(define-module (gnu packages freetype)
#:use-module (gnu packages)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages xml)
#:use-module ((guix licenses) #:renamer (symbol-prefix-proc 'license:))
@@ -105,3 +106,42 @@ metric information. But t1lib is in itself entirely independent of the
X11-system or any other graphical user interface. ")
(license license:gpl2)
(home-page "http://www.t1lib.org/")))
+
+(define-public teckit
+ (package
+ (name "teckit")
+ (version "2.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://scripts.sil.org/svn-view/teckit/TAGS/TECkit_"
+ (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
+ ".tar.gz"))
+ (sha256 (base32
+ "0fjiwvic8mdxpkyccfp7zh26y9xnvkp0skqbyfkrjiacd191k82r"))))
+ (build-system gnu-build-system)
+ (inputs `(("patch/teckit" ,(search-patch "teckit-cstdio.patch"))
+ ("zlib" ,zlib)))
+ (arguments
+ `(#:patches (list (assoc-ref %build-inputs "patch/teckit"))))
+ (synopsis "TECkit, a toolkit for encoding conversions")
+ (description
+ "TECkit is a low-level toolkit intended to be used by other applications
+that need to perform encoding conversions (e.g., when importing legacy data
+into a Unicode-based application). The primary component of the TECkit
+package is therefore a library that performs conversions; this is the
+\"TECkit engine\". The engine relies on mapping tables in a specific binary
+format (for which documentation is available); there is a compiler that
+creates such tables from a human-readable mapping description (a simple
+text file).
+
+To facilitate the development and testing of mapping tables for TECkit,
+several applications are also included in the current package; these
+include simple tools for applying conversions to plain-text and Standard
+Format files, as well as both command-line and simple GUI versions of the
+TECkit compiler. However, it is not intended that these tools will be the
+primary means by which end users perform conversions, and they have not
+been designed, tested, and debugged to the extent that general-purpose
+applications should be.")
+ (license license:lgpl2.1+)
+ (home-page "http://scripts.sil.org/cms/scripts/page.php?cat_id=teckit")))
diff --git a/gnu/packages/patches/teckit-cstdio.patch b/gnu/packages/patches/teckit-cstdio.patch
new file mode 100644
index 0000000000..d79595ed44
--- /dev/null
+++ b/gnu/packages/patches/teckit-cstdio.patch
@@ -0,0 +1,10 @@
+--- TECkit_2_5_1/source/Compiler.cpp 2008-04-07 16:21:12.000000000 +0200
++++ TECkit_2_5_1/source/Compiler.cpp 2013-01-26 00:33:18.000000000 +0100
+@@ -29,6 +29,7 @@
+
+ #include "Compiler.h"
+
++#include <cstdio>
+ #include <iostream>
+ #include <iomanip>
+ #include <algorithm>