aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:59:34 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:13 +0200
commite28d5c9e8c791a2649e11674eb5fc0d93d2aed96 (patch)
treed393bdd277eb516a03253a3f0dc953f93a5ee311 /gnu
parent58f557778a129428c8d9a7ee4c5c7fce6b316b33 (diff)
downloadguix-e28d5c9e8c791a2649e11674eb5fc0d93d2aed96.tar
guix-e28d5c9e8c791a2649e11674eb5fc0d93d2aed96.tar.gz
gnu: Add texlive-xistercian.
* gnu/packages/tex.scm (texlive-xistercian): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e836b3060e..031945dde1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5739,6 +5739,31 @@ ordinary text, and as a picture element within a TikZ-picture. The appearance
of a flag (size, frame etc.) can be adapted using optional parameters.")
(license license:lppl1.3+)))
+(define-public texlive-xistercian
+ (package
+ (name "texlive-xistercian")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/xistercian/"
+ "source/latex/xistercian/"
+ "tex/latex/xistercian/")
+ (base32
+ "021iwd8w19dbj1iqm1fdf9s06lysbrackz0g897nmsf0fks6qf4r")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xistercian")
+ (synopsis "Cistercian numerals in LaTeX")
+ (description
+ "@code{xistercian} allows you to use Cistercian numerals in LaTeX.
+The glyphs are created using PGF and to a certain degree configurable. You
+can use Cistercian numerals as page numbers using
+@code{\\pagenumbering@{cistercian@}}. The two main macros are:
+@code{\\cistercian@{<counter>@}}, which formats the LaTeX2e counter as
+a Cistercian numeral, and @code{\\cisterciannum@{<integer>@}}, formats the
+integer (given as a string) as a Cistercian numeral.")
+ (license license:lppl1.3c)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")