aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-03 23:35:43 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-03 23:35:43 +0100
commite13f715be0d609073974b1d464771638887a00c6 (patch)
tree5890eae5659678fe77b9f198a0aae207ba3f0e4f /gnu
parent4b2fd119befd4b4fdeb596bfc12fa0082ba94507 (diff)
downloadguix-e13f715be0d609073974b1d464771638887a00c6.tar
guix-e13f715be0d609073974b1d464771638887a00c6.tar.gz
gnu: libtool: Add 2.4.4.
* gnu/packages/patches/libtool-2.4-skip-tests.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/autotools.scm (libtool-2.4.4): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/autotools.scm19
-rw-r--r--gnu/packages/patches/libtool-2.4-skip-tests.patch24
2 files changed, 42 insertions, 1 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 0094577210..3d5c85463f 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -291,3 +291,20 @@ presenting a single consistent, portable interface that hides the usual
complexity of working with shared libraries across platforms.")
(license gpl3+)
(home-page "http://www.gnu.org/software/libtool/")))
+
+(define-public libtool-2.4.4
+ (package (inherit libtool)
+ (version "2.4.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/libtool/libtool-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0v3zq08qxv7k5067mpqrkjkjl3wphhg06i696mka90mzadc5nad8"))
+ (patches
+ (list (search-patch "libtool-2.4-skip-tests.patch")))))
+
+ (native-inputs `(("automake" ,automake) ;some tests rely on 'aclocal'
+ ("autoconf" ,(autoconf-wrapper)) ;others on 'autom4te'
+ ,@(package-native-inputs libtool)))))
diff --git a/gnu/packages/patches/libtool-2.4-skip-tests.patch b/gnu/packages/patches/libtool-2.4-skip-tests.patch
new file mode 100644
index 0000000000..95747dfef0
--- /dev/null
+++ b/gnu/packages/patches/libtool-2.4-skip-tests.patch
@@ -0,0 +1,24 @@
+Because our GCC 'lib' spec automatically adds '-rpath' for each '-L'
+and a couple more '-rpath, there are two test failures:
+one in demo.test, and one in destdir.at. Disable these.
+
+--- libtool-2.4.4/tests/testsuite 2014-11-29 17:43:11.000000000 +0100
++++ libtool-2.4.4/tests/testsuite 2015-01-03 23:00:09.367775122 +0100
+@@ -9185,7 +9185,7 @@ read at_status <"$at_status_file"
+ #AT_START_33
+ at_fn_group_banner 33 'demo.at:548' \
+ "hardcoding library path" " " 3
+-at_xfail=no
++at_xfail=yes
+ test no = "$ACLOCAL" && at_xfail=yes
+ test no = "$AUTOHEADER" && at_xfail=yes
+ test no = "$AUTOMAKE" && at_xfail=yes
+@@ -27052,7 +27052,7 @@ read at_status <"$at_status_file"
+ #AT_START_97
+ at_fn_group_banner 97 'destdir.at:75' \
+ "DESTDIR with in-package deplibs" " " 7
+-at_xfail=no
++at_xfail=yes
+ eval `$LIBTOOL --config | $GREP '^fast_install='`
+ case $fast_install in no) :;; *) false;; esac && at_xfail=yes
+ (