aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-08 09:27:11 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-08 09:27:26 +0200
commite0819e5ca2d59d87ba6c16a6149e7b18faf60543 (patch)
tree739e88a73b31b1c0268bfb773de3a364cfb979f7 /gnu
parentbc5aa386675cb39aaf034d73af406c3ddffb4cb0 (diff)
downloadguix-e0819e5ca2d59d87ba6c16a6149e7b18faf60543.tar
guix-e0819e5ca2d59d87ba6c16a6149e7b18faf60543.tar.gz
gnu: Add emacs-tao-theme.
* gnu/packages/emacs-xyz.scm (emacs-tao-theme): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index afb55cb902..f3de24d825 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18171,3 +18171,32 @@ JIRA issue servers.")
"This packages fontifies the ssh config keywords and creates
keybindings for skipping from host section to host section.")
(license license:gpl3+))))
+
+(define-public emacs-tao-theme
+ (let ((commit "c5107fbe7e752f4e58c2d2147ff18a1ebb12937c")
+ (revision "0"))
+ (package
+ (name "emacs-tao-theme")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/11111000000/tao-theme-emacs.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07vvlglmkj87hpxz79s3bl2cjn71vain57fdxs7j9vlr5jkchxwn"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/11111000000/tao-theme-emacs")
+ (synopsis "Parameterized uncolored color themes for Emacs")
+ (description
+ "This package provides two parameterized uncolored color themes for
+Emacs: @code{tao-yin} and @code{tao-yang}. The default
+@code{tao-theme-scale-fn} is @code{tao-theme-golden-scale}.
+
+You can customize: @code{tao-theme-scale-fn}, that returns 16 2-digit numbers;
+@code{tao-theme-scale-filter-fn}, for edge filter; and
+@code{tao-theme-use-height}.")
+ (license license:gpl3+))))