aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-07-13 09:33:30 -0300
committerVinicius Monego <monego@posteo.net>2024-07-14 10:24:01 -0300
commitdfd91f101a1ad0fe86ea1484bf7974a3184a95ff (patch)
tree22d69088aaf7a0a7d04fe80c87dac59ec36fa08c /gnu
parent67afc0afa3835dd7005a661838731387a5b0518d (diff)
downloadguix-dfd91f101a1ad0fe86ea1484bf7974a3184a95ff.tar
guix-dfd91f101a1ad0fe86ea1484bf7974a3184a95ff.tar.gz
gnu: python-hy: Reformat with 'guix style'.
* gnu/packages/python-xyz.scm (python-hy): Reformat package using 'guix style'. Change-Id: Ie7dadd33fca2cabefcb83c3f50826752ad2c8a98
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b8db6c41da..88f19c0f55 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18407,7 +18407,7 @@ with a new public API, and RPython support.")
(version "0.29.0")
(source
(origin
- (method git-fetch) ; no tests in PyPI release
+ (method git-fetch) ;no tests in PyPI release
(uri (git-reference
(url "https://github.com/hylang/hy")
(commit version)))
@@ -18416,13 +18416,12 @@ with a new public API, and RPython support.")
(base32 "0fp5x94hyckjfap2pb1rj551a3q70vrljxark7hj9kdhr7prbggi"))))
(build-system pyproject-build-system)
(arguments
- ;; This test expects the hy executable to be called 'hy', but in Guix
- ;; it's .hy-real.
- (list #:test-flags #~(list "-k" "not test_sys_executable")))
- (native-inputs
- (list python-pytest-next python-wheel))
- (propagated-inputs
- (list python-funcparserlib))
+ (list
+ ;; This test expects the hy executable to be called 'hy', but in Guix
+ ;; it's .hy-real.
+ #:test-flags #~(list "-k" "not test_sys_executable")))
+ (native-inputs (list python-pytest-next python-wheel))
+ (propagated-inputs (list python-funcparserlib))
(home-page "https://docs.hylang.org/en/stable/")
(synopsis "Lisp frontend to Python")
(description