aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:00:15 +0100
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:16:02 +0000
commitdf2d6e9aec92fcc9b39e0118222170b414860ee1 (patch)
treeb096e924c7696d02e4ec44e3e3ca1ef70ac81a49 /gnu
parentfeff79e47a49f3687510dae9e8c1e213be8ba0de (diff)
downloadguix-df2d6e9aec92fcc9b39e0118222170b414860ee1.tar
guix-df2d6e9aec92fcc9b39e0118222170b414860ee1.tar.gz
gnu: Add ruby-sass.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0715e8d8ee..a131d0e809 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7099,3 +7099,37 @@ https://github.com/flavorjones/loofah-activerecord).")
(home-page
"http://i.loveruby.net/en/projects/racc/")
(license license:expat)))
+
+(define-public ruby-sass
+ (package
+ (name "ruby-sass")
+ (version "3.4.22")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "sass" version))
+ (sha256
+ (base32
+ "0dkj6v26fkg1g0majqswwmhxva7cd6p3psrhdlx93qal72dssywy"))))
+ (build-system ruby-build-system)
+ (arguments
+ ;; Cannot run sass-spec options because the sass-spec package does
+ ;; not work. TODO: Fix.
+ `(#:test-target "test:ruby"))
+ (native-inputs
+ `(("ruby-rubycop" ,ruby-rubocop)
+ ("ruby-ruby-progressbar" ,ruby-ruby-progressbar)))
+ (synopsis
+ " Sass makes CSS fun again. Sass is an extension of CSS, adding
+ nested rules, variables, mixins, selector inheritance, and more.
+ It's translated to well-formatted, standard CSS using the
+ command line tool or a web-framework plugin.
+")
+ (description
+ " Sass makes CSS fun again. Sass is an extension of CSS, adding
+ nested rules, variables, mixins, selector inheritance, and more.
+ It's translated to well-formatted, standard CSS using the
+ command line tool or a web-framework plugin.
+")
+ (home-page "http://sass-lang.com/")
+ (license license:expat)))