aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-11 11:38:31 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-11 13:15:39 +0100
commitddeb0130549014c2b3f3c52766ae8bbd4f7265f0 (patch)
tree7ee0311982b63f971160c701469150c6a1c2570e /gnu
parent63e36f3a8b518af9c5d21ce4c69661322eec25bb (diff)
downloadguix-ddeb0130549014c2b3f3c52766ae8bbd4f7265f0.tar
guix-ddeb0130549014c2b3f3c52766ae8bbd4f7265f0.tar.gz
gnu: go-mvdan-cc-xurls: Update to 2.5.0.
* gnu/packages/golang.scm (go-mvdan-cc-xurls): Update to 2.5.0. [propagated-inputs]: Add go-golang-org-x-mod. (xurls) [arguments]: <#:phases>: Add disable-failing-tests phase. Change-Id: If9e2b955218913cb237eef7f643dab1d72fa129f
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 16 insertions, 6 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index fafc05c8f9..2d7e2d1011 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7495,7 +7495,7 @@ That is, @code{gofumpt} is happy with a subset of the formats that
(define-public go-mvdan-cc-xurls
(package
(name "go-mvdan-cc-xurls")
- (version "2.4.0")
+ (version "2.5.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -7504,11 +7504,14 @@ That is, @code{gofumpt} is happy with a subset of the formats that
(file-name (git-file-name name version))
(sha256
(base32
- "0b040nbk1vwlk1qljavh8w8fn2r243q700n6gr8j2asmnz0xq84p"))))
+ "1516hwlxbnhdca56qy7sx9h2n5askq6ddqpqyp3f5rvmzdkxf4zn"))))
(build-system go-build-system)
(arguments
`(#:import-path "mvdan.cc/xurls/v2"))
- (inputs (list go-golang-org-x-sync go-github-com-rogpeppe-go-internal))
+ (propagated-inputs
+ (list go-github-com-rogpeppe-go-internal
+ go-golang-org-x-mod
+ go-golang-org-x-sync))
(home-page "https://mvdan.cc/xurls/v2/")
(synopsis "Extracts URLs from text")
(description
@@ -7521,9 +7524,16 @@ be used as both a binary and a library.")
(inherit go-mvdan-cc-xurls)
(name "xurls")
(arguments
- `(#:import-path "mvdan.cc/xurls/v2/cmd/xurls"
- #:unpack-path "mvdan.cc/xurls/v2"
- #:install-source? #f))))
+ (list
+ #:import-path "mvdan.cc/xurls/v2/cmd/xurls"
+ #:unpack-path "mvdan.cc/xurls/v2"
+ #:install-source? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (delete-file "testdata/script/version.txtar")))))))))
(define-public go-github-com-davecgh-go-xdr
(package