aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-12 11:24:45 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-09-12 11:26:05 +0300
commitd4869b7e43d823bccc8f6d81dd9f5d2c13cb8f25 (patch)
tree8bc60bc02918f3b5264a5a376dfc8160f42c7d27 /gnu
parentca3803d6e26863022c05c5973dc0a2c52c000ee0 (diff)
downloadguix-d4869b7e43d823bccc8f6d81dd9f5d2c13cb8f25.tar
guix-d4869b7e43d823bccc8f6d81dd9f5d2c13cb8f25.tar.gz
gnu: julia-genericlinearalgebra: Skip some tests on aarch64-linux.
* gnu/packages/julia-xyz.scm (julia-genericlinearalgebra)[arguments]: When building for aarch64-linux add a phase to skip two tests. Change-Id: I9aedee8fc0a4aec77181a3b3c6ab25412882f077
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index d800f861df..b068dee61f 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2519,6 +2519,19 @@ update step.")
(sha256
(base32 "16k1r02w5qivvr99n5a9impbnnzygpj705irf5ypy208np91xyyd"))))
(build-system julia-build-system)
+ (arguments
+ (list
+ #:phases
+ (if (target-aarch64?)
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-some-tests
+ (lambda _
+ (substitute* "test/lapack.jl"
+ (("@testset.*stedc.*" all)
+ (string-append all "return\n"))
+ (("@testset.*stemr.*" all)
+ (string-append all "return\n"))))))
+ #~%standard-phases)))
(native-inputs
(list julia-quaternions))
(home-page "https://github.com/JuliaLinearAlgebra/GenericLinearAlgebra.jl")