aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:31:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:59 +0200
commitd3c9796d77786196d5a04f3bd579cce0a65fd21b (patch)
tree8dee61c025b584c5650ff623fc2ab9bb86f658e5 /gnu
parent7f62cf37bf71a2df88430ab7592ac2e87ae8d8c5 (diff)
downloadguix-d3c9796d77786196d5a04f3bd579cce0a65fd21b.tar
guix-d3c9796d77786196d5a04f3bd579cce0a65fd21b.tar.gz
gnu: Add texlive-messagepassing.
* gnu/packages/tex.scm (texlive-messagepassing): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 438899a780..af2f53b681 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4751,6 +4751,30 @@ styles that ease the declaration of memory graphs. It is intended for graphs
that represent the memory of a computer program during its execution.")
(license license:lppl1.3+)))
+(define-public texlive-messagepassing
+ (package
+ (name "texlive-messagepassing")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/messagepassing/"
+ "source/latex/messagepassing/"
+ "tex/latex/messagepassing/")
+ (base32
+ "0m0ig8rhg7y1gv59cg4ask7n24i6k3jwhci2didh87vh598jg9x1")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/messagepassing")
+ (synopsis "Draw diagrams to represent communication protocols")
+ (description
+ "This package provides an environment to easily draw diagrams to
+represent communication protocols using message passing among processes.
+Processes are represented as horizontal or vertical lines, and communications
+as arrows between lines. The package also provides multiple macros to
+decorate those diagrams, for instance to annotate the diagram, to add crashes
+to the processes, checkpoints, ...")
+ (license license:lppl1.3+)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")