aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-06-27 19:48:47 -0400
committerMark H Weaver <mhw@netris.org>2015-06-30 00:17:00 -0400
commitd2e3caba5da7e85d009c614d1d53b35e6efc9285 (patch)
treec73182c2dcd94154bbedf8bba6b0d0cbf00f1b8d /gnu
parent4617c2e383f366472d2cfec3bcb7974e7d66ca2c (diff)
downloadguix-d2e3caba5da7e85d009c614d1d53b35e6efc9285.tar
guix-d2e3caba5da7e85d009c614d1d53b35e6efc9285.tar.gz
gnu: curl: Disable test that fails on Hydra.
* gnu/packages/curl.scm (arguments): Disable test 1510.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/curl.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 03fd365174..1e72a57a07 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -73,6 +73,25 @@
;; simply disable the test as it is specific to VMS and OS/400.
(delete-file "tests/data/test1135")
+ ;; XXX FIXME: Test #1510 seems to work on some machines and not
+ ;; others, possibly based on the kernel version. It works on GuixSD
+ ;; on x86_64 with linux-libre-4.1, but fails on Hydra for both i686
+ ;; and x86_64 with the following error:
+ ;;
+ ;; test 1510...[HTTP GET connection cache limit (CURLOPT_MAXCONNECTS)]
+ ;;
+ ;; 1510: output (log/stderr1510) FAILED:
+ ;; --- log/check-expected 2015-06-27 07:45:53.166720834 +0000
+ ;; +++ log/check-generated 2015-06-27 07:45:53.166720834 +0000
+ ;; @@ -1,5 +1,5 @@
+ ;; * Connection #0 to host server1.example.com left intact[LF]
+ ;; * Connection #1 to host server2.example.com left intact[LF]
+ ;; * Connection #2 to host server3.example.com left intact[LF]
+ ;; -* Closing connection 0[LF]
+ ;; +* Closing connection 1[LF]
+ ;; * Connection #3 to host server4.example.com left intact[LF]
+ (delete-file "tests/data/test1510")
+
;; The top-level "make check" does "make -C tests quiet-test", which
;; is too quiet. Use the "test" target instead, which is more
;; verbose.