aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:33:05 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:44 +0200
commitd20f4970dac6bea33b73195efbe11a5fa4c12bf2 (patch)
tree1e5824725b3caff7bcbf8fc6ccb3905e3253ad10 /gnu
parentd628311856d1f2690e5ef34d3179e4e15f885ffc (diff)
downloadguix-d20f4970dac6bea33b73195efbe11a5fa4c12bf2.tar
guix-d20f4970dac6bea33b73195efbe11a5fa4c12bf2.tar.gz
gnu: Add texlive-pst-slpe.
* gnu/packages/tex.scm (texlive-pst-slpe): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b8ba137615..6823badbb5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33973,6 +33973,37 @@ diagram of a system, drawing adaptive systems, sequentially connecting a list
of nodes, and connecting a list of nodes using any node-connecting macro.")
(license license:lppl)))
+(define-public texlive-pst-slpe
+ (package
+ (name "texlive-pst-slpe")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/pst-slpe/" "dvips/pst-slpe/"
+ "source/generic/pst-slpe/"
+ "tex/generic/pst-slpe/"
+ "tex/latex/pst-slpe/")
+ (base32
+ "12m6iss3hqsngq2dk7n3d1zz6z2rq4j2w1di9l26hpzly2mdp26n")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pst-slpe")
+ (synopsis "Sophisticated colour gradients")
+ (description
+ "This PStricks package covers all the colour gradient functionality of
+@code{pst-grad} (part of the base PSTricks distribution), and provides the
+following facilities:
+
+@itemize
+@item it permits the user to specify an arbitrary number of colours, along
+with the points at which they are to be reached;
+@item it converts between RGB and HSV behind the scenes;
+@item it provides concentric and radial gradients;
+@item it provides a command @code{\\psBall} that generates bullets with
+a three-dimensional appearance.
+@end itemize")
+ (license license:lppl)))
+
(define-public texlive-pst-text
(package
(name "texlive-pst-text")