aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-19 21:23:13 -0500
committerMark H Weaver <mhw@netris.org>2014-12-19 23:28:17 -0500
commitd0088ad82a9683c4c8fc02fb6f056c9d32e4e8f2 (patch)
tree3eb1015a5416c272c9f38cb0ced5709908dd570a /gnu
parentaf339a482e0dbd3c86f1f3cceb79f25bf4212763 (diff)
downloadguix-d0088ad82a9683c4c8fc02fb6f056c9d32e4e8f2.tar
guix-d0088ad82a9683c4c8fc02fb6f056c9d32e4e8f2.tar.gz
gnu: xf86-video-trident: Update to 1.3.6.
* gnu/packages/patches/xf86-video-trident-remove-mibstore.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/xorg.scm (xf86-video-trident): Update to 1.3.6. Add patch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patches/xf86-video-trident-remove-mibstore.patch23
-rw-r--r--gnu/packages/xorg.scm8
2 files changed, 28 insertions, 3 deletions
diff --git a/gnu/packages/patches/xf86-video-trident-remove-mibstore.patch b/gnu/packages/patches/xf86-video-trident-remove-mibstore.patch
new file mode 100644
index 0000000000..74c89878e7
--- /dev/null
+++ b/gnu/packages/patches/xf86-video-trident-remove-mibstore.patch
@@ -0,0 +1,23 @@
+Removes references to mibstore.h and miInitializeBackingStore, which
+have been removed from xorg-server. Zack Rusin <zackr@vmware.com>
+wrote: "It was a noop for at least 5 years and it has been removed."
+See: http://patches.openembedded.org/patch/46133/
+
+--- xf86-video-trident-1.3.6/src/trident_driver.c.~1~ 2012-07-15 22:16:00.000000000 -0400
++++ xf86-video-trident-1.3.6/src/trident_driver.c 2014-12-19 01:45:29.529410518 -0500
+@@ -56,7 +56,6 @@
+
+ #include "mipointer.h"
+
+-#include "mibstore.h"
+ #include "shadow.h"
+ #include "trident.h"
+ #include "trident_regs.h"
+@@ -3037,7 +3036,6 @@
+ TridentAccelInit(pScreen);
+ }
+
+- miInitializeBackingStore(pScreen);
+ xf86SetBackingStore(pScreen);
+
+ /* Initialise cursor functions */
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 3f6c7b9639..b3de71f54d 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2997,17 +2997,19 @@ kernel mode setting (KMS).")
(define-public xf86-video-trident
(package
(name "xf86-video-trident")
- (version "1.3.5")
+ (version "1.3.6")
(source
(origin
(method url-fetch)
(uri (string-append
- "mirror://xorg/X11R7.7/src/everything/xf86-video-trident-"
+ "mirror://xorg/individual/driver/xf86-video-trident-"
version
".tar.bz2"))
(sha256
(base32
- "02y5pzdp0a1c12jr8gghbrzgbyfbgq67x7kd7n4f323pmf8x1csb"))))
+ "0141qbfsm32i0pxjyx5czpa8x8m4lvapsp4amw1qigaa0gry6n3a"))
+ (patches (list
+ (search-patch "xf86-video-trident-remove-mibstore.patch")))))
(build-system gnu-build-system)
(inputs `(("xf86dgaproto" ,xf86dgaproto)
("xorg-server" ,xorg-server)))