aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-06-18 22:43:43 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-19 14:25:55 +0100
commitcb0b42a8d4e4c6d4d435f04dd5b3da009bb79d08 (patch)
tree1db5ce92b72055ce92d816377586438a5626cc80 /gnu
parent68347f87449186aa2880ce07d2d68cf67fa8cd43 (diff)
downloadguix-cb0b42a8d4e4c6d4d435f04dd5b3da009bb79d08.tar
guix-cb0b42a8d4e4c6d4d435f04dd5b3da009bb79d08.tar.gz
gnu: Add go-github-com-warpfork-go-testmark.
* gnu/packages/golang-check.scm (go-github-com-warpfork-go-testmark): New variable. Change-Id: Ie8c4524ead7f6199dc9de92c1de86e6ad2289512 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-check.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 3fc628a202..1caf1e6069 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1034,6 +1034,33 @@ custom assertions to be used alongside native Go testing.")
(arguments
(list #:import-path "github.com/go-playground/assert/v2"))))
+(define-public go-github-com-warpfork-go-testmark
+ (package
+ (name "go-github-com-warpfork-go-testmark")
+ (version "0.12.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/warpfork/go-testmark")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06v2x3c5qgbj585a2abksr3hgvgdx61j153rjarqi9cvvzwh1xpr"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "github.com/warpfork/go-testmark"))
+ (home-page "https://github.com/warpfork/go-testmark")
+ (synopsis "Parser for @code{testmark} format")
+ (description
+ "@code{go-testmark} is a library to parse, patch data and test fixtures from
+Markdown files, using the
+@url{https://github.com/warpfork/go-testmark?tab=readme-ov-file#what-is-the-testmark-format,
+testmark} format, which itself is a subset of Markdown format.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public go-github-com-warpfork-go-wish
(package
(name "go-github-com-warpfork-go-wish")