aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-15 20:22:51 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-12-15 20:22:51 +0100
commitca0262ad5eb8eeaa2f936cb86cc723c229eadf91 (patch)
tree8c723fd70ca33c9f3ec2e79735b2aa85756d66ec /gnu
parente4aeec2fe44fd047b51a0093990fcac992ae745c (diff)
downloadguix-ca0262ad5eb8eeaa2f936cb86cc723c229eadf91.tar
guix-ca0262ad5eb8eeaa2f936cb86cc723c229eadf91.tar.gz
gnu: python-xarray: Disable bad tests.
* gnu/packages/python-science.scm (python-xarray)[arguments]: Disable two tests. Change-Id: Ia9799a5bd247907ee875925431cd0fe2714f51b3
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-science.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 42a64aed6e..05c6ac1fc1 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1899,7 +1899,11 @@ multiple deep learning frameworks.")
;; These are known to fail with Pandas 2
"-k"
(string-append "not test_datetime_conversion_warning"
- " and not test_timedelta_conversion_warning"))))
+ " and not test_timedelta_conversion_warning"
+ ;; These expect deprecation warnings that are not
+ ;; emitted in our case.
+ " and not test_drop_index_labels"
+ " and not test_rename_multiindex"))))
(native-inputs
(list python-setuptools python-setuptools-scm python-pytest python-wheel))
(propagated-inputs