aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-12-14 19:23:29 +0100
committerLudovic Courtès <ludo@gnu.org>2013-12-14 19:23:29 +0100
commitc94d01bab2714b963048e965955652d0f91ebd56 (patch)
treef95312163abdded1ee00bc1ea9e8356d704530bf /gnu
parent52a79f1e73f9489b1c89c001f65ca2097e40e92b (diff)
downloadguix-c94d01bab2714b963048e965955652d0f91ebd56.tar
guix-c94d01bab2714b963048e965955652d0f91ebd56.tar.gz
gnu: tzdata: Fix cross-compilation.
Reported by John Darrington <john@darrington.wattle.id.au>. * gnu/packages/base.scm (tzdata): Use the 'source' keyword argument in phases rather than the "source" input. This fixes cross-compilation.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 02f1b91392..e17933b36f 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -520,8 +520,8 @@ with the Linux kernel.")
#:phases
(alist-replace
'unpack
- (lambda* (#:key inputs #:allow-other-keys)
- (and (zero? (system* "tar" "xvf" (assoc-ref inputs "source")))
+ (lambda* (#:key source inputs #:allow-other-keys)
+ (and (zero? (system* "tar" "xvf" source))
(zero? (system* "tar" "xvf" (assoc-ref inputs "tzcode")))))
(alist-cons-after
'install 'post-install