aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-12 17:35:23 +0100
committerMarius Bakke <marius@gnu.org>2020-12-13 21:44:10 +0100
commitc8e83277d5242af03261fbc713d36da6dbad3afd (patch)
tree8426f3dafebad87835f9a5428643709a0b565678 /gnu
parentd0a0f789466e5a1583a8bf3417d2da8e5c4e414d (diff)
downloadguix-c8e83277d5242af03261fbc713d36da6dbad3afd.tar
guix-c8e83277d5242af03261fbc713d36da6dbad3afd.tar.gz
gnu: python-babel: Update to 2.9.0.
* gnu/packages/python-xyz.scm (python-babel): Update to 2.9.0. [arguments]: Do not disable any tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bfe005dc30..333f7255c5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -680,14 +680,14 @@ by @code{binstar}, @code{binstar-build}, and @code{chalmers}.")
(define-public python-babel
(package
(name "python-babel")
- (version "2.8.0")
+ (version "2.9.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Babel" version))
(sha256
(base32
- "0f0f2vvs1mpdpz2c0mg1mnc3sih8bizmc1h9m67kdsnqs3i2mb0s"))))
+ "018yg7g2pa6vjixx1nx41cfispgfi0azzp0a1chlycbj8jsil0ys"))))
(build-system python-build-system)
(native-inputs
`(("python-freezegun" ,python-freezegun)
@@ -698,13 +698,7 @@ by @code{binstar}, @code{binstar-build}, and @code{chalmers}.")
`(#:phases (modify-phases %standard-phases
(replace 'check
(lambda _
- (invoke "pytest" "-vv" "-k"
- (string-append
- ;; XXX: These tests fail when using Pytest 4.x and
- ;; Babel 2.6.0. Try removing this for later versions.
- "not test_no_inherit_metazone_marker_never_in_output"
- " and not test_smoke_dates"
- " and not test_smoke_numbers")))))))
+ (invoke "pytest" "-vv"))))))
(home-page "http://babel.pocoo.org/")
(synopsis
"Tools for internationalizing Python applications")