aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-05-25 16:26:16 +0200
committerLudovic Courtès <ludo@gnu.org>2013-05-25 16:26:16 +0200
commitc8c6bba5a7001adef4f79a83c00cc24b697e8ed4 (patch)
tree0d87f205999b5edc6cc11242657e9986b3f28a5f /gnu
parentde59af4d6d1f6143c063878b451f9fe163eed982 (diff)
downloadguix-c8c6bba5a7001adef4f79a83c00cc24b697e8ed4.tar
guix-c8c6bba5a7001adef4f79a83c00cc24b697e8ed4.tar.gz
gnu: sed: Allow cross-compilation.
* gnu/packages/base.scm (sed): Keep the default phases when (%current-target-system) is true.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm22
1 files changed, 12 insertions, 10 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index b1bc5ca2d1..4452108abf 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -101,16 +101,18 @@ lines.")
(build-system gnu-build-system)
(synopsis "Stream editor")
(arguments
- `(#:phases (alist-cons-before
- 'patch-source-shebangs 'patch-test-suite
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((bash (assoc-ref inputs "bash")))
- (patch-makefile-SHELL "testsuite/Makefile.tests")
- (substitute* '("testsuite/bsd.sh"
- "testsuite/bug-regex9.c")
- (("/bin/sh")
- (string-append bash "/bin/bash")))))
- %standard-phases)))
+ (if (%current-target-system)
+ '()
+ `(#:phases (alist-cons-before
+ 'patch-source-shebangs 'patch-test-suite
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((bash (assoc-ref inputs "bash")))
+ (patch-makefile-SHELL "testsuite/Makefile.tests")
+ (substitute* '("testsuite/bsd.sh"
+ "testsuite/bug-regex9.c")
+ (("/bin/sh")
+ (string-append bash "/bin/bash")))))
+ %standard-phases))))
(description
"Sed (stream editor) isn't really a true text editor or text processor.
Instead, it is used to filter text, i.e., it takes text input and performs