aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-15 16:55:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:23 +0200
commitc7d9f162a12082921e60c1c37018cc0d94881119 (patch)
tree1e71e59d5d0b0894c0315690f931e00e6c5f6680 /gnu
parentbc64ba55c987e037651f867f04a6532165a8d506 (diff)
downloadguix-c7d9f162a12082921e60c1c37018cc0d94881119.tar
guix-c7d9f162a12082921e60c1c37018cc0d94881119.tar.gz
gnu: Add texlive-synctex.
* gnu/packages/tex.scm (texlive-synctex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0d7e88e7f8..56dfd0acb1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11352,6 +11352,28 @@ of which make use of the @code{stackengine} core.")
"The package provides macros for drawing Chinese and Japanese abaci.")
(license license:lppl)))
+(define-public texlive-synctex
+ (package
+ (name "texlive-synctex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/synctex.1"
+ "doc/man/man1/synctex.man1.pdf"
+ "doc/man/man5/synctex.5"
+ "doc/man/man5/synctex.man5.pdf")
+ (base32
+ "1a2nlmbib8723jjhf6xxh5rpmnd5jv3cd69br4ihchbq5ipzircp")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/synctex")
+ (synopsis "Engine-level feature synchronizing output and source")
+ (description
+ "SyncTeX allows navigating between the TeX source and (usually PDF)
+output, in both directions, given a SyncTeX-aware front end. It is compiled
+into most engines and can be enabled with the @samp{--synctex=1} option.")
+ (license license:expat)))
+
(define-public texlive-tetragonos
(package
(name "texlive-tetragonos")