aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-07-07 10:13:02 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-07 14:37:40 +0100
commitc6fae8a300cca29a45d6acf9bf804ef9a71bb6cd (patch)
tree47428a3ef9099af4a27bc16954d6026d22d6e28f /gnu
parentd4fdac60bf0237c3eea10c8f2bf60e85fe74217d (diff)
downloadguix-c6fae8a300cca29a45d6acf9bf804ef9a71bb6cd.tar
guix-c6fae8a300cca29a45d6acf9bf804ef9a71bb6cd.tar.gz
gnu: Add go-github-com-whyrusleeping-cbor-gen.
* gnu/packages/ipfs.scm (go-github-com-whyrusleeping-cbor-gen): New variable. Change-Id: I7fc01ba570492a145bcea00f08e0ccb7cc0479af Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ipfs.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index bdfa88bd94..2248c6f3cd 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -449,6 +449,34 @@ their levels to be controlled individually.")
#:go go-1.21
#:import-path "github.com/ipfs/go-log"))))
+(define-public go-github-com-whyrusleeping-cbor-gen
+ (package
+ (name "go-github-com-whyrusleeping-cbor-gen")
+ (version "v0.0.0-20230818171029-f91ae536ca25")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/whyrusleeping/cbor-gen")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08by7pqh4fcwf2va01iif75yqkfssi6d48334404mmv9jmhzim60"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/whyrusleeping/cbor-gen"))
+ (propagated-inputs
+ (list go-github-com-ipfs-go-cid
+ go-github-com-google-go-cmp-cmp
+ go-golang-org-x-xerrors))
+ (home-page "https://github.com/whyrusleeping/cbor-gen")
+ (synopsis "Codegen for CBOR codecs on the specified types")
+ (description
+ "Basic utilities to generate fast path @url{https://cbor.io/, CBOR} codecs for
+types.")
+ (license license:expat)))
+
(define-public gx
(package
(name "gx")