aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-05-27 10:01:52 -0500
committerEric Bavier <bavier@member.fsf.org>2014-05-27 10:05:32 -0500
commitc1448c69747c7e8bd2a2e911b96c7f2837fee691 (patch)
treeceb11edc4a96135674d9aed5854610820abec4e4 /gnu
parentf4561be2d13668bbb38dcb01d8bfe56c8c12bf0f (diff)
downloadguix-c1448c69747c7e8bd2a2e911b96c7f2837fee691.tar
guix-c1448c69747c7e8bd2a2e911b96c7f2837fee691.tar.gz
gnu: Add python-lockfile.
* gnu/packages/python.scm (python-lockfile): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d3d4f390ff..53d1f3edb4 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -21,7 +21,7 @@
(define-module (gnu packages python)
#:use-module ((guix licenses)
- #:select (bsd-3 bsd-style psfl x11 x11-style
+ #:select (bsd-3 bsd-style expat psfl x11 x11-style
gpl2 gpl2+ lgpl2.1+))
#:use-module ((guix licenses) #:select (zlib)
#:renamer (symbol-prefix-proc 'license:))
@@ -293,6 +293,30 @@ etc. ")
(define-public python2-babel
(package-with-python2 python-babel))
+(define-public python-lockfile
+ (package
+ (name "python-lockfile")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/l/lockfile/"
+ "lockfile-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0iwif7i84gwpvrnpv4brshdk8j6l77smvknm8k3bg77mj6f5ini3"))))
+ (build-system python-build-system)
+ (arguments '(#:test-target "check"))
+ (home-page "http://code.google.com/p/pylockfile/")
+ (synopsis "Platform-independent file locking module")
+ (description
+ "The lockfile package exports a LockFile class which provides a simple
+API for locking files.")
+ (license expat)))
+
+(define-public python2-lockfile
+ (package-with-python2 python-lockfile))
+
(define-public python-setuptools
(package