aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-03-30 23:48:13 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-31 14:16:13 +0200
commitc000352c27f511dfb5569bef09f9b774d6100117 (patch)
treeca8f6b37cfd0506db1c4440ab1f2bf45fedb031a /gnu
parent3b57a9cac8962068a3abad1aa09477e9a433460e (diff)
downloadguix-c000352c27f511dfb5569bef09f9b774d6100117.tar
guix-c000352c27f511dfb5569bef09f9b774d6100117.tar.gz
gnu: Replace all uses of atk by at-spi2-core.
* gnu/packages/animation.scm (gnash) * gnu/packages/chromium.scm (ungoogled-chromium) * gnu/packages/crates-gtk.scm (rust-atk-sys-0.14, rust-atk-sys-0.10, rust-atk-0.14, rust-gtk-0.14) * gnu/packages/gimp.scm (gimp) * gnu/packages/gnome.scm (evince, glade3, clutter, totem, rhythmbox, mutter, ghex): * gnu/packages/graphviz.scm (xdot) * gnu/packages/gtk.scm (gtk+-2, gtk+, guile-gnome, atkmm) * gnu/packages/mate.scm (mate-applets, atril, mate-control-center, mate-calc, mate-utils, eom, pluma) * gnu/packages/messaging.scm (dino) * gnu/packages/qt.scm (qtwebengine-5) * gnu/packages/rust-apps.scm (alfis) * gnu/packages/vim.scm (vim-full) * gnu/packages/vnc.scm (remmina) * gnu/packages/web.scm (castor): Replace atk by at-spi2-core. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/animation.scm2
-rw-r--r--gnu/packages/chromium.scm1
-rw-r--r--gnu/packages/crates-gtk.scm8
-rw-r--r--gnu/packages/gimp.scm2
-rw-r--r--gnu/packages/gnome.scm14
-rw-r--r--gnu/packages/graphviz.scm2
-rw-r--r--gnu/packages/gtk.scm9
-rw-r--r--gnu/packages/mate.scm14
-rw-r--r--gnu/packages/messaging.scm2
-rw-r--r--gnu/packages/qt.scm2
-rw-r--r--gnu/packages/rust-apps.scm2
-rw-r--r--gnu/packages/vim.scm2
-rw-r--r--gnu/packages/vnc.scm2
-rw-r--r--gnu/packages/web.scm2
14 files changed, 31 insertions, 33 deletions
diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index 33fc3fcce9..4c03b78717 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -260,7 +260,7 @@ contains the graphical user interface for synfig.")
("python" ,python-wrapper)))
(inputs
`(("agg" ,agg)
- ("atk" ,atk)
+ ("at-spi2-core" ,at-spi2-core)
("boost" ,boost)
("curl" ,curl)
("ffmpeg" ,ffmpeg-2.8)
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index 47153e3531..22e22cdbf8 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -898,7 +898,6 @@
wayland))
(inputs
(list alsa-lib
- atk
at-spi2-core
cups
curl
diff --git a/gnu/packages/crates-gtk.scm b/gnu/packages/crates-gtk.scm
index 403c1f2aef..1c99c87bb6 100644
--- a/gnu/packages/crates-gtk.scm
+++ b/gnu/packages/crates-gtk.scm
@@ -60,7 +60,7 @@
("rust-tempfile" ,rust-tempfile-3))))
(native-inputs (list pkg-config))
(inputs
- (list atk glib))
+ (list at-spi2-core glib))
(home-page "https://gtk-rs.org/")
(synopsis "FFI bindings to libatk-1")
(description "FFI bindings to libatk-1")
@@ -90,7 +90,7 @@
("rust-tempfile" ,rust-tempfile-3))))
(native-inputs (list pkg-config))
(inputs
- (list atk glib))))
+ (list at-spi2-core glib))))
(define-public rust-atk-sys-0.9
(package
@@ -138,7 +138,7 @@
#:cargo-development-inputs
(("rust-gir-format-check" ,rust-gir-format-check-0.1))))
(inputs
- (list atk glib))
+ (list at-spi2-core glib))
(home-page "https://gtk-rs.org/")
(synopsis "Rust bindings for the ATK library")
(description "Rust bindings for the ATK library")
@@ -1469,7 +1469,7 @@
(("rust-gir-format-check" ,rust-gir-format-check-0.1))))
(native-inputs (list pkg-config))
(inputs
- (list atk cairo glib gtk+ pango))
+ (list at-spi2-core cairo glib gtk+ pango))
(home-page "https://gtk-rs.org/")
(synopsis "Rust bindings for the GTK+ 3 library")
(description "This package provides Rust bindings for the GTK+ 3 library.")
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index af5adb8bfd..73102e30cf 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -333,7 +333,7 @@ buffers.")
;; ./configure requests not to annoy upstream with packaging bugs.
"--with-bug-report-url=https://bugs.gnu.org/guix")))
(inputs
- (list atk
+ (list at-spi2-core
babl
gegl
gexiv2
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e2ee396819..e81882b181 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2704,7 +2704,7 @@ forgotten when the session ends.")
libgnome-keyring
adwaita-icon-theme
gdk-pixbuf
- atk
+ at-spi2-core
pango
gtk+
glib
@@ -3299,7 +3299,7 @@ API add-ons to make GTK+ widgets OpenGL-capable.")
'())
(list gtk+ libxml2)))
(native-inputs
- (list atk ;for tests
+ (list at-spi2-core ;for tests
docbook-xml-4.2
docbook-xsl
gettext-minimal
@@ -6357,7 +6357,7 @@ without stepping on each others toes.")
libxslt
pkg-config))
(propagated-inputs
- (list atk
+ (list at-spi2-core
cairo
cogl
glib
@@ -6744,7 +6744,7 @@ discovery protocols.")
(inputs
(list gtk+
gdk-pixbuf
- atk
+ at-spi2-core
cairo
dbus-glib
xorgproto
@@ -6866,7 +6866,7 @@ which can read a large number of file formats.")
;;clutter-gtk
;;clutter-gst
(list adwaita-icon-theme
- atk
+ at-spi2-core
bash-minimal
brasero
json-glib
@@ -8021,7 +8021,7 @@ to display dialog boxes from the commandline and shell scripts.")
(list gsettings-desktop-schemas-next ;required by libmutter.pc
gtk+ ;required by libmutter.pc
;; mutter-clutter-1.0.pc and mutter-cogl-1.0.pc refer to these:
- atk
+ at-spi2-core
cairo
eudev
gdk-pixbuf
@@ -11646,7 +11646,7 @@ micro-pauses and rest breaks, and restricts you to your daily limit.")
pkg-config
yelp-tools))
(inputs
- (list atk
+ (list at-spi2-core
gtk))
(synopsis "GNOME hexadecimal editor")
(description "The GHex program can view and edit files in two ways:
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index aa3cee6e5b..d98041d73a 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -346,7 +346,7 @@ Graphviz and LaTeX.")
`("PATH" ":" prefix
(,(dirname (search-input-file inputs "bin/dot"))))))))))
(inputs
- (list atk
+ (list at-spi2-core
(librsvg-for-system)
harfbuzz
graphviz
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 65854e0ba0..a19c9c372b 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -934,7 +934,7 @@ is part of the GNOME accessibility project.")
(build-system gnu-build-system)
(outputs '("out" "bin" "doc" "debug"))
(propagated-inputs
- (list atk
+ (list at-spi2-core
cairo
glib
(librsvg-for-system)
@@ -1030,8 +1030,7 @@ application suites.")
(patches (search-patches "gtk3-respect-GUIX_GTK3_PATH.patch"
"gtk3-respect-GUIX_GTK3_IM_MODULE_FILE.patch"))))
(propagated-inputs
- (list atk
- at-spi2-core
+ (list at-spi2-core
cairo
fribidi
fontconfig
@@ -1587,7 +1586,7 @@ documents.")
(build-system gnu-build-system)
(native-inputs
(list pkg-config
- atk
+ at-spi2-core
;;("corba" ,corba) ; not packaged yet
gconf
gobject-introspection
@@ -1797,7 +1796,7 @@ text rendering library.")
("python" ,python)
("xsltproc" ,libxslt)))
(propagated-inputs
- (list glibmm atk))
+ (list glibmm at-spi2-core))
(synopsis "C++ bindings for ATK")
(description "ATKmm is the C++ binding for the ATK library.")
(home-page "https://wiki.gnome.org/Accessibility")
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 2f38946fe1..4874aaf7f9 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -521,7 +521,7 @@ assorted menu related utility programs.")
docbook-xml
gobject-introspection))
(inputs
- (list atk
+ (list at-spi2-core
dbus
dbus-glib
glib
@@ -732,7 +732,7 @@ infamous 'Wanda the Fish'.")
("xmllint" ,libxml2)
("zlib" ,zlib)))
(inputs
- `(("atk" ,atk)
+ `(("at-spi2-core" ,at-spi2-core)
("cairo" ,cairo)
("caja" ,caja)
("dconf" ,dconf)
@@ -921,7 +921,7 @@ icons on the MATE desktop. It works on local and remote file systems.")
xmodmap
gobject-introspection))
(inputs
- `(("atk" ,atk)
+ `(("at-spi2-core" ,at-spi2-core)
("cairo" ,cairo)
("caja" ,caja)
("dconf" ,dconf)
@@ -1061,7 +1061,7 @@ sessions, panels, menus, file management, and preferences.")
(native-inputs
(list gettext-minimal intltool pkg-config yelp-tools))
(inputs
- (list atk
+ (list at-spi2-core
glib
gtk+
libxml2
@@ -1228,7 +1228,7 @@ can be used as backgrounds in the MATE Desktop environment.")
xorgproto
yelp-tools))
(inputs
- (list atk
+ (list at-spi2-core
cairo
glib
gtk+
@@ -1277,7 +1277,7 @@ can be used as backgrounds in the MATE Desktop environment.")
pkg-config
yelp-tools))
(inputs
- (list atk
+ (list at-spi2-core
cairo
dconf
dbus
@@ -1382,7 +1382,7 @@ can be used as backgrounds in the MATE Desktop environment.")
("pkg-config" ,pkg-config)
("yelp-tools" ,yelp-tools)))
(inputs
- (list atk
+ (list at-spi2-core
cairo
enchant-1.6
glib
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index bbd1743cac..1cef8d4811 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1373,7 +1373,7 @@ Encryption to Gajim.")
vala))
(inputs
(list adwaita-icon-theme
- atk
+ at-spi2-core
bash-minimal
cairo
librsvg
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 0208312bd5..407ae1dd5d 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2640,7 +2640,7 @@ using the Enchant spell-checking library.")
ruby))
(inputs
(list alsa-lib
- atk
+ at-spi2-core
cups-minimal
curl
dbus
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index b8cb06af64..5ec82009af 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -177,7 +177,7 @@ low-end hardware and serving many concurrent requests.")
(native-inputs
(list pkg-config))
(inputs
- (list atk
+ (list at-spi2-core
gtk
glib
pango
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 6baf10915a..d555194d0b 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -243,7 +243,7 @@ with the editor vim.")))
(prepend pkg-config xorg-server-for-tests)))
(inputs
`(("acl" ,acl)
- ("atk" ,atk)
+ ("at-spi2-core" ,at-spi2-core)
("attr" ,attr)
("cairo" ,cairo)
("fontconfig" ,fontconfig)
diff --git a/gnu/packages/vnc.scm b/gnu/packages/vnc.scm
index fc272ae621..37c9ae0619 100644
--- a/gnu/packages/vnc.scm
+++ b/gnu/packages/vnc.scm
@@ -123,7 +123,7 @@
pkg-config))
(inputs
(list libappindicator
- atk
+ at-spi2-core
avahi
cairo
cups
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b1d6e8768b..24f5021889 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6628,7 +6628,7 @@ file links.")
(native-inputs
(list pkg-config))
(inputs
- (list atk
+ (list at-spi2-core
cairo
gdk-pixbuf
gtk+