aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-11-04 15:02:31 +0000
committerLudovic Courtès <ludo@gnu.org>2023-12-04 22:26:37 +0100
commitbbb33a12fecdf4be98f09fba62e84c91d545fe31 (patch)
treeeac9b0fe5c6a661923c6c66bf3c3c984dad96f7a /gnu
parentf76ffc3ea607aa65820aaa87d9b681ba535a7e5d (diff)
downloadguix-bbb33a12fecdf4be98f09fba62e84c91d545fe31.tar
guix-bbb33a12fecdf4be98f09fba62e84c91d545fe31.tar.gz
gnu: Add python-matplotx.
* gnu/packages/python-xyz.scm (python-matplotx): New variable. Change-Id: I354732edeaa30cbae506e78a16f42e66edb3011b Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm39
1 files changed, 38 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f87e6fc3f7..6552ddba88 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -108,7 +108,7 @@
;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
;;; Copyright © 2021, 2022, 2023 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
;;; Copyright © 2021, 2022 Pradana Aumars <paumars@courrier.dev>
-;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2021, 2022, 2023 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Sébastien Lerique <sl@eauchat.org>
;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
;;; Copyright © 2021 ZmnSCPxj <ZmnSCPxj@protonmail.com>
@@ -8297,6 +8297,43 @@ Jupyter.")
three-way Venn diagrams in @code{matplotlib}.")
(license license:expat)))
+(define-public python-matplotx
+ (package
+ (name "python-matplotx")
+ (version "0.3.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nschloe/matplotx")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1j301mr7ai2jmbm5mkva0jd99fzxhyq585pqzqfmrf5pil8j4q8i"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-matplotlib
+ python-numpy
+ ;; optional dependencies
+ python-networkx
+ python-pypng
+ python-scipy))
+ (native-inputs (list python-imageio
+ python-meshzoo
+ python-pytest
+ python-scikit-fem))
+ (arguments
+ (list
+ #:test-flags
+ ;; This test fails with ValueError: not enough values to unpack.
+ #~(list "--deselect" "tests/test_spy.py::test_cli")))
+ (home-page "https://github.com/nschloe/matplotx")
+ (synopsis "Minimal matplotlib styles")
+ (description
+ "This package includes some extensions for Matplotlib to create
+clean plots with a minimalistic style.")
+ (license license:expat)))
+
(define-public python-pysnptools
(package
(name "python-pysnptools")