aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTom Fitzhenry <tom@tom-fitzhenry.me.uk>2022-06-24 21:08:34 +1000
committerLudovic Courtès <ludo@gnu.org>2022-08-08 17:26:18 +0200
commitbb907402a613494e7fb6f8f04bf8d9d16ff9ee66 (patch)
tree88d4fd11c8f46924bb91aed7d4c60ed35b039b18 /gnu
parent8ed15dedbeea04e96e0a81592d43c64f8ba3ee72 (diff)
downloadguix-bb907402a613494e7fb6f8f04bf8d9d16ff9ee66.tar
guix-bb907402a613494e7fb6f8f04bf8d9d16ff9ee66.tar.gz
gnu: Add ruby-hydra-minimal.
* gnu/local.mk (dist_patch_DATA): Add ruby-hydra-minimal-no-byebug.patch. * gnu/packages/patches/ruby-hydra-minimal-no-byebug.patch: New file. * gnu/packages/ruby.scm (ruby-hydra): Refactor to inherit from ruby-hydra-minimal. (ruby-hydra-minimal): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/ruby.scm36
2 files changed, 26 insertions, 11 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index bb8514c0d9..4cf006dd60 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1772,6 +1772,7 @@ dist_patch_DATA = \
%D%/packages/patches/rocm-comgr-3.1.0-dependencies.patch \
%D%/packages/patches/rocm-opencl-runtime-4.3-noclinfo.patch \
%D%/packages/patches/rocm-opencl-runtime-4.3-noopencl.patch \
+ %D%/packages/patches/ruby-hydra-minimal-no-byebug.patch \
%D%/packages/patches/ruby-mustache-1.1.1-fix-race-condition-tests.patch \
%D%/packages/patches/ruby-sanitize-system-libxml.patch \
%D%/packages/patches/rustc-1.54.0-src.patch \
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index c1e3dca807..38330901b3 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3124,24 +3124,40 @@ two hashes.")
(home-page "https://github.com/liufengyun/hashdiff")
(license license:expat)))
-(define-public ruby-hydra
+(define-public ruby-hydra-minimal
;; No releases yet.
(let ((commit "5abfa378743756ae4d9306cc134bcc482f5c9525")
(revision "0"))
(package
- (name "ruby-hydra")
+ (name "ruby-hydra-minimal")
(version (git-version "0.0" revision commit))
(home-page "https://github.com/hyphenation/hydra")
(source (origin
(method git-fetch)
(uri (git-reference (url home-page) (commit commit)))
(file-name (git-file-name name version))
+ ;; byebug is a non-essential debugging utility that brings in
+ ;; many dependencies.
+ (patches (search-patches "ruby-hydra-minimal-no-byebug.patch"))
(sha256
(base32
"1cik398l2765y3d9sdhjzki3303hkry58ac6jlkiy7iy62nm529f"))))
(build-system ruby-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
+ ;; Avoid rspec dependency.
+ '(#:tests? #f))
+ (synopsis "Ruby hyphenation patterns")
+ (description
+ "ruby-hydra-minimal is a Ruby library for working with hyphenation patterns.
+It is a low-dependency variant of ruby-hydra.")
+ (license license:expat))))
+
+(define-public ruby-hydra
+ (package
+ (inherit ruby-hydra-minimal)
+ (name "ruby-hydra")
+ (arguments
+ '(#:phases (modify-phases %standard-phases
(add-after 'unpack 'make-files-writable
(lambda _
(for-each make-file-writable (find-files "."))
@@ -3149,14 +3165,12 @@ two hashes.")
(replace 'check
(lambda _
(invoke "rspec"))))))
- (native-inputs
- (list ruby-rspec))
- (propagated-inputs
- (list ruby-byebug))
- (synopsis "Ruby hyphenation patterns")
- (description
- "ruby-hydra is a Ruby library for working with hyphenation patterns.")
- (license license:expat))))
+ (native-inputs
+ (list ruby-rspec))
+ (propagated-inputs
+ (list ruby-byebug))
+ (description
+ "ruby-hydra is a Ruby library for working with hyphenation patterns.")))
(define-public ruby-shindo
(package