aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-29 15:59:04 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:37 +0000
commitb93c0e8542b74f330cfb2e8cff5c61ee856144ba (patch)
tree884e9189c125591c4b95fa5810217b86984560d5 /gnu
parentaa8a25221f29b837506d01edb37f7b0f6ae8e6a0 (diff)
downloadguix-b93c0e8542b74f330cfb2e8cff5c61ee856144ba.tar
guix-b93c0e8542b74f330cfb2e8cff5c61ee856144ba.tar.gz
gnu: python-cwcwidth: Update to 0.1.9.
* gnu/packages/python-xyz.scm (python-cwcwidth): Update to 0.1.9. Improve style. [build-system]: Swap to pyproject-build-system. [arguments]<phases>: Add 'build-extensions. [native-inputs]: Add python-setuptools. Change-Id: Ifccd290dbcb1655eb8b78956187602d774cf7927
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 19 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8854d7655f..24eb19c84f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -35686,23 +35686,33 @@ Generalized Mark-up Language}.")
(define-public python-cwcwidth
(package
(name "python-cwcwidth")
- (version "0.1.4")
+ (version "0.1.9")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cwcwidth" version))
(sha256
- (base32
- "1azrphpkcyggg38xvkfb9dpc4xmmm90p02kf8dkqd4d6j5w96aj8"))))
- (build-system python-build-system)
+ (base32 "1f3nvc4f2icg0c285bl6l4ak9km8pj9nxjb4s2n8qjld2jh137gi"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'build-extensions
+ (lambda _
+ (invoke "python" "setup.py" "build_ext" "--inplace"))))))
(native-inputs
- (list python-cython python-pytest python-setuptools-scm python-toml
+ (list python-cython
+ python-pytest
+ python-setuptools
+ python-setuptools-scm
+ python-toml
python-wheel))
- (home-page
- "https://github.com/sebastinas/cwcwidth")
+ (home-page "https://github.com/sebastinas/cwcwidth")
(synopsis "Python bindings for wc(s)width")
- (description "This package provides bindings for wcwidth and wcswidth
-functions defined in POSIX.1-2001 and POSIX.1-2008.")
+ (description
+ "This package provides bindings for wcwidth and wcswidth functions
+defined in POSIX.1-2001 and POSIX.1-2008.")
(license license:expat)))
(define-public python-pyan3