aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-07 16:26:43 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-07 18:44:04 +0100
commitb614009e6a8c965ef73d8d65e99d44b933f9eb12 (patch)
tree86ec720a6a3c1063cd5ef0a637156f9f07b6d6fc /gnu
parentfbebccf7f6459a7543defbbdb98abd26e9ac56e6 (diff)
downloadguix-b614009e6a8c965ef73d8d65e99d44b933f9eb12.tar
guix-b614009e6a8c965ef73d8d65e99d44b933f9eb12.tar.gz
gnu: Add r-sparsesvd.
* gnu/packages/cran.scm (r-sparsesvd): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6551811d49..9aa6e3b270 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8724,3 +8724,26 @@ R packages (on CRAN, Bioconductor or Github).")
"This package enables you to define a command-line interface by just
giving it a description in the specific format.")
(license license:expat)))
+
+(define-public r-sparsesvd
+ (package
+ (name "r-sparsesvd")
+ (version "0.1-4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "sparsesvd" version))
+ (sha256
+ (base32
+ "1yf373552wvdnd65r7hfcqa3v29dqn7jd4cn431mqd2acnqjrsam"))))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-matrix" ,r-matrix)))
+ (home-page "http://tedlab.mit.edu/~dr/SVDLIBC/")
+ (synopsis "Sparse truncated singular value decomposition")
+ (description
+ "This package provides a Wrapper around the SVDLIBC library
+for (truncated) singular value decomposition of a sparse matrix. Currently,
+only sparse real matrices in Matrix package format are supported.")
+ ;; SVDLIBC is released under BSD-2. The R interface is released under
+ ;; BSD-3.
+ (license (list license:bsd-3 license:bsd-2))))