aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 10:19:44 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:04 +0800
commitb5834e880afce846aeee843964d5756f4693b010 (patch)
treec28b4463a4bad80496056a5e4acb3a8b8bb1ebc8 /gnu
parent7b30b1e741436f161f7b96f44af33c34f7ad4ed8 (diff)
downloadguix-b5834e880afce846aeee843964d5756f4693b010.tar
guix-b5834e880afce846aeee843964d5756f4693b010.tar.gz
gnu: Add ksvg.
* gnu/packages/kde-frameworks.scm (ksvg): New variable. Change-Id: I7b5eec1f32015c3d76178af705c59bbb3fcf60bd
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 0bf82a02f1..080258b7d3 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1075,6 +1075,44 @@ data being plotted. KPlotWidget automatically converts everything to screen
pixel units.")
(license license:lgpl2.1+)))
+(define-public ksvg
+ (package
+ (name "ksvg")
+ (version "6.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "15n7schzmwq4z0yiw0l1js45mml5wq3syb5vc7j9hs88j1jdcp6q"))))
+ (build-system qt-build-system)
+ (native-inputs
+ (list extra-cmake-modules qttools))
+ (inputs
+ (list
+ qtdeclarative
+ qtsvg
+ karchive
+ kconfig
+ kcolorscheme
+ kcoreaddons
+ kguiaddons
+ kirigami))
+ (arguments
+ (list #:qtbase qtbase
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda _
+ (setenv "HOME" (getcwd)))))))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Components for handling SVGs")
+ (description "A library for rendering SVG-based themes with stylesheet
+re-coloring and on-disk caching.")
+ (license license:lgpl2.1+)))
+
(define-public ksyntaxhighlighting
(package
(name "ksyntaxhighlighting")