aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2024-05-01 10:00:54 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2024-05-01 10:05:42 +0300
commitb32d129ad945052c6755b0cc4970f7827821553c (patch)
treedbaf28703298cc9c234a6db5d0f28ea524691883 /gnu
parent7d7fca19429cf9d38125610f46333eb02fc2d3fd (diff)
downloadguix-b32d129ad945052c6755b0cc4970f7827821553c.tar
guix-b32d129ad945052c6755b0cc4970f7827821553c.tar.gz
gnu: bats: Update to 1.11.0.
* gnu/packages/bash.scm (bats)[version]: Update to 1.11.0. [arguments]<#:builder>: Filter out symlinks in patch-shebang. Change-Id: I74405b99f91172c10b8c81caa0f3f46e1df4d74e
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bash.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index bb3359d5d1..9ecec0a484 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2024 Oleg Pykhalov <go.wigust@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -368,7 +369,7 @@ capturing.")
(define-public bats
(package
(name "bats")
- (version "1.2.0")
+ (version "1.11.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -377,7 +378,7 @@ capturing.")
(file-name (git-file-name name version))
(sha256
(base32
- "0f59zh4d4pa1a7ybs5zl6h0csbqqv11lbnq0jl1dgwm1s6p49bsq"))))
+ "1dmgxcqq87vs1l23hb7ghx319w2nvn0w8z2kdxggs2b8n22wi0c2"))))
(inputs
(list bash coreutils guile-3.0 ;for wrap-script
grep))
@@ -393,7 +394,12 @@ capturing.")
":" (assoc-ref %build-inputs "grep") "/bin"
":" (assoc-ref %build-inputs "guile") "/bin"
":" (getenv "PATH")))
- (for-each (lambda (file) (patch-shebang file)) (find-files "."))
+ (for-each patch-shebang
+ (find-files "."
+ (lambda (file stat)
+ ;; Filter out symlinks.
+ (eq? 'regular (stat:type stat)))
+ #:stat lstat))
(substitute* "bin/bats"
(("export BATS_ROOT" line)
(string-append "BATS_ROOT=\"${BATS_ROOT:-" %output "/libexec/bats-core}\"\n"