aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLu Hui <luhux76@gmail.com>2022-01-01 15:53:22 +0800
committerLeo Famulari <leo@famulari.name>2022-01-02 12:42:56 -0500
commitb2ed92ec58ea122e96b2f2b00f43af254b305c75 (patch)
tree62f3fb5256d170fc3343b0c665f4485b6da0eb49 /gnu
parent1dca8a19ef5c6232cd1461e7a61f23ddd72bb973 (diff)
downloadguix-b2ed92ec58ea122e96b2f2b00f43af254b305c75.tar
guix-b2ed92ec58ea122e96b2f2b00f43af254b305c75.tar.gz
gnu: uim: Fix build with GCC 10.
* gnu/packages/xorg.scm (uim)[arguments]: Pass "-O2 -g -fcommon" to #:configure-flags. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index fcaae30664..9ebad82351 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 qblade <qblade@protonmail.com>
+;;; Copyright © 2021 Lu Hui <luhux76@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6467,7 +6468,8 @@ X11 servers, Windows, or macOS.")
(list "--with-anthy-utf8"
(string-append "--with-lispdir=" %output "/share/emacs")
;; Set proper runpath
- (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
+ (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib")
+ "CFLAGS=-O2 -g -fcommon")
#:phases
(modify-phases %standard-phases
;; Set path of uim-el-agent and uim-el-helper-agent executables