aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-07-21 20:41:59 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-07-21 20:41:59 +0200
commitb20436276864e452f52906db97e70a1557a78acc (patch)
tree5536a4b25c6a293f8d5a630b80fd3628ee64e676 /gnu
parent0f0a82fa13c39c2e35b6353e2332ea674475f5b9 (diff)
downloadguix-b20436276864e452f52906db97e70a1557a78acc.tar
guix-b20436276864e452f52906db97e70a1557a78acc.tar.gz
gnu: emacs-jupyter: Update to 1.0-1.f97f4b5.
* gnu/packages/emacs-xyz.scm (emacs-jupyter): Update to 1.0-1.f97f4b5. This bump is necessary to fix build, broken since last EMACS-ZMQ update, in commit 57b37bc3999565505fb9e9bc752d840ccfd7de56. Change-Id: I4cf1513cd5d99a77e0f3c6d47ed84d9ae2d37976
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm48
1 files changed, 25 insertions, 23 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a8310e21f8..ecdb2acc63 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22941,32 +22941,34 @@ the pipeline, featuring the support for running @code{emacsclient}.")
(license license:gpl3+)))
(define-public emacs-jupyter
- (package
- (name "emacs-jupyter")
- (version "1.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/nnicandro/emacs-jupyter")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0rf8d83bzc05v0w7zpqwcd89cdvrxwzpyf55vmmzj5j755bgxvhs"))))
- (build-system emacs-build-system)
- (propagated-inputs
- (list emacs-company ;optional
- emacs-markdown-mode ;optional
- emacs-simple-httpd
- emacs-websocket
- emacs-zmq))
- (home-page "https://github.com/nnicandro/emacs-jupyter")
- (synopsis "Emacs interface to communicate with Jupyter kernels")
- (description "This package provides an Emacs interface to communicate with
+ (let ((commit "f97f4b5d8c83e0b901020f835183dde8a2bf649e")
+ (revision "1"))
+ (package
+ (name "emacs-jupyter")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nnicandro/emacs-jupyter")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jmhh9ncnf4ai8rr2g474n6dv9m7v983s2w0smy0h7l07sp43klq"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-company ;optional
+ emacs-markdown-mode ;optional
+ emacs-simple-httpd
+ emacs-websocket
+ emacs-zmq))
+ (home-page "https://github.com/nnicandro/emacs-jupyter")
+ (synopsis "Emacs interface to communicate with Jupyter kernels")
+ (description "This package provides an Emacs interface to communicate with
Jupyter kernels. It provides REPL and Org mode source code block frontends to
Jupyter kernels and kernel interactions integrated with Emacs' built-in
features.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-hcl-mode
(package