aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJames Smith <jsubuntuxp@disroot.org>2024-07-04 16:23:47 -0700
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-07-13 08:10:02 +0200
commitaaf157deb36880e6f7fe8c057b98302dca04c1dc (patch)
treeb507adf1c8eb76a51bdfb0c2115f2c00c155b16b /gnu
parent947d44f1b3e7dd312f69847d2b7ecb1fd3ac7a4a (diff)
downloadguix-aaf157deb36880e6f7fe8c057b98302dca04c1dc.tar
guix-aaf157deb36880e6f7fe8c057b98302dca04c1dc.tar.gz
gnu: lollypop: Update package style.
* gnu/packages/gnome.scm (lollypop)[arguments]: Convert to list of G-Expressions. Change-Id: I2f7e0157f65bdd6776fbf15214093a837c5b0fd6 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm36
1 files changed, 18 insertions, 18 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a63a7537b0..88e647dd65 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11566,24 +11566,24 @@ views can be printed as PDF or PostScript files, or exported to HTML.")
(base32 "1laj5xwfz2bz29scga2ahhnhlgll4a0n21wwy8mlr4jsl81g0jsa"))))
(build-system meson-build-system)
(arguments
- `(#:imported-modules (,@%meson-build-system-modules
- (guix build python-build-system))
- #:modules ((guix build meson-build-system)
- ((guix build python-build-system) #:prefix python:)
- (guix build utils))
- #:glib-or-gtk? #t
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-gtk-update-icon-cache
- (lambda _
- (setenv "DESTDIR" "/")))
- (add-after 'install 'wrap-program
- (lambda* (#:key outputs #:allow-other-keys)
- (wrap-program (search-input-file outputs "bin/lollypop")
- `("GI_TYPELIB_PATH" ":" prefix
- (,(getenv "GI_TYPELIB_PATH"))))))
- (add-after 'install 'wrap-python
- (assoc-ref python:%standard-phases 'wrap)))))
+ (list #:imported-modules `(,@%meson-build-system-modules
+ (guix build python-build-system))
+ #:modules '((guix build meson-build-system)
+ ((guix build python-build-system) #:prefix python:)
+ (guix build utils))
+ #:glib-or-gtk? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-gtk-update-icon-cache
+ (lambda _
+ (setenv "DESTDIR" "/")))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (wrap-program (search-input-file outputs "bin/lollypop")
+ (list "GI_TYPELIB_PATH" ":" 'prefix
+ (list (getenv "GI_TYPELIB_PATH"))))))
+ (add-after 'install 'wrap-python
+ (assoc-ref python:%standard-phases 'wrap)))))
(native-inputs
(list gettext-minimal
`(,glib "bin") ; For glib-compile-resources