aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-22 23:12:19 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-22 23:13:42 +0100
commita8fe564d7504f2831b22eb309e7d88f5746cde30 (patch)
tree1b2ea8ed179e287d8fc0b13ed629fd1b4e47f979 /gnu
parent0bf887f29ccbd7efb00d1635bd45453c51f4d785 (diff)
downloadguix-a8fe564d7504f2831b22eb309e7d88f5746cde30.tar
guix-a8fe564d7504f2831b22eb309e7d88f5746cde30.tar.gz
gnu: Add go-github-com-pion-sctp.
* gnu/packages/golang-web.scm (go-github-com-pion-sctp): New variable. Change-Id: Ib7f3f9437d126995469441cca430e72c6f1d51c3
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index b204280317..547e8a0811 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2272,6 +2272,37 @@ part of @url{https://github.com/pion, Pion} WebRTC implementation.")
packetizer and depacketizer.")
(license license:expat)))
+(define-public go-github-com-pion-sctp
+ (package
+ (name "go-github-com-pion-sctp")
+ (version "1.8.19")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/sctp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19yzpyrlmk3gvpkpn5846rad9cc8ffxw9jqwnpr6szqax7k0l0zw"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/pion/sctp"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-pion-logging
+ go-github-com-pion-randutil
+ go-github-com-pion-transport-v3))
+ (home-page "https://github.com/pion/sctp")
+ (synopsis "Implementation of SCTP in Golang")
+ (description
+ "This package implements the @acronym{Stream Control Transmission
+Protocol,SCTP} as specified in
+@uref{https://rfc-editor.org/rfc/rfc9260.html,RFC 9260}.")
+ (license license:expat)))
+
(define-public go-github-com-pion-stun
(package
(name "go-github-com-pion-stun")