aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-05-25 21:36:45 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-05-27 18:46:38 +0200
commita1a5ef2094a99bf97dd3e260c6b74bee4d4c861e (patch)
treed38e652603a5f5905007b622bc131743dad63bf7 /gnu
parent9b9db6c482a203ff8526a53460ab7308c2f4da81 (diff)
downloadguix-a1a5ef2094a99bf97dd3e260c6b74bee4d4c861e.tar
guix-a1a5ef2094a99bf97dd3e260c6b74bee4d4c861e.tar.gz
gnu: Add java-jsr250.
* gnu/packages/java.scm (java-jsr250): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 90fd07c597..d109c3fd62 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
-;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2017, 2018 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -4263,6 +4263,33 @@ from within Java, as well as an object registry that exposes Java objects to
these scripting language engines.")
(license license:asl2.0)))
+(define-public java-jsr250
+ (package
+ (name "java-jsr250")
+ (version "1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://repo1.maven.org/maven2/"
+ "javax/annotation/javax.annotation-api/"
+ version "/javax.annotation-api-"
+ version "-sources.jar"))
+ (sha256
+ (base32
+ "08clh8n4n9wfglf75qsqfjs6yf79f7x6hqx38cn856pksszv50kz"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:tests? #f ; no tests included
+ #:jdk ,icedtea-8
+ #:jar-name "jsr250.jar"))
+ (home-page "https://jcp.org/en/jsr/detail?id=250")
+ (synopsis "Security-related annotations")
+ (description "This package provides annotations for security. It provides
+packages in the @code{javax.annotation} and @code{javax.annotation.security}
+namespaces.")
+ ;; either cddl or gpl2 only, with classpath exception
+ (license (list license:cddl1.0
+ license:gpl2))))
+
(define-public java-jsr305
(package
(name "java-jsr305")