aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-06-28 17:02:40 -0400
committerLeo Famulari <leo@famulari.name>2018-06-28 19:40:03 -0400
commita0135eeefca194d82313d0cb4b15a4f6954c0400 (patch)
tree4d3be7316c34cc6da832f4520e89a6b88be966ba /gnu
parente689d8fab0515171cc8fafb9555368b46359ee99 (diff)
downloadguix-a0135eeefca194d82313d0cb4b15a4f6954c0400.tar
guix-a0135eeefca194d82313d0cb4b15a4f6954c0400.tar.gz
gnu: Add qtfaststart.
* gnu/packages/video.scm (qtfaststart): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ce90d470f4..b5fb169893 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2018 Roel Janssen <roel@gnu.org>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
+;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2974,3 +2975,27 @@ format and some of its derived file formats, including MP4. It operates as a
multiplexer and demultiplexer, and can mux video and audio in several formats
using standalone executable files.")
(license license:isc)))
+
+(define-public qtfaststart
+ (package
+ (name "qtfaststart")
+ (version "1.8")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "qtfaststart" version))
+ (sha256
+ (base32
+ "0hcjfik8hhb1syqvyh5c6aillpvzal26nkjflcq1270z64aj6i5h"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; no test suite
+ (synopsis "Move QuickTime and MP4 metadata to the beginning of the file")
+ (description "qtfaststart enables streaming and pseudo-streaming of
+QuickTime and MP4 files by moving metadata and offset information to the
+beginning of the file. It can also print some useful information about the
+structure of the file. This program is based on qt-faststart.c from the FFmpeg
+project, which is released into the public domain, as well as ISO 14496-12:2005
+(the official spec for MP4), which can be obtained from the ISO or found
+online.")
+ (home-page "https://github.com/danielgtaylor/qtfaststart")
+ (license license:expat)))