aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-12-13 18:01:04 +0100
committerLudovic Courtès <ludo@gnu.org>2013-12-13 18:09:01 +0100
commit9ed1ba8ae2ea788b96a80c0fb87252a789bb3fe0 (patch)
treec0111980b541e9369f24049c66b08ed3868863de /gnu
parent31f9322e6fdecc6addcf8a67e0200bf1f457a7d7 (diff)
downloadguix-9ed1ba8ae2ea788b96a80c0fb87252a789bb3fe0.tar
guix-9ed1ba8ae2ea788b96a80c0fb87252a789bb3fe0.tar.gz
gnu: global: Install the elisp file under $out/share/emacs/site-lisp.
* gnu/packages/global.scm (global)[arguments]: Add #:phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/global.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/global.scm b/gnu/packages/global.scm
index 2d4cd31bd9..6244e2461e 100644
--- a/gnu/packages/global.scm
+++ b/gnu/packages/global.scm
@@ -42,7 +42,21 @@
(arguments
`(#:configure-flags
(list (string-append "--with-ncurses="
- (assoc-ref %build-inputs "ncurses")))))
+ (assoc-ref %build-inputs "ncurses")))
+
+ #:phases (alist-cons-after
+ 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Install the Emacs Lisp file in the right place.
+ (let* ((out (assoc-ref outputs "out"))
+ (data (string-append out "/share/gtags"))
+ (lisp (string-append out "/share/emacs/site-lisp")))
+ (mkdir-p lisp)
+ (copy-file (string-append data "/gtags.el")
+ (string-append lisp "/gtags.el"))
+ (delete-file (string-append data "/gtags.el"))
+ #t))
+ %standard-phases)))
(home-page "http://www.gnu.org/software/global/")
(synopsis "Cross-environment source code tag system")
(description