aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-12-07 06:18:28 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-12 16:18:17 +0100
commit9c81ab8b3930a45277fdc2aad086120f47350421 (patch)
treeacef541e5f632e91d2cf274db10c4ad3058015bd /gnu
parent977a15d8e8e85c1cf074df4a28b9923a8827d959 (diff)
downloadguix-9c81ab8b3930a45277fdc2aad086120f47350421.tar
guix-9c81ab8b3930a45277fdc2aad086120f47350421.tar.gz
gnu: Add r-stable.
* gnu/packages/cran.scm (r-stable): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 46652a7d13..90dd74e0c2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6452,6 +6452,28 @@ color labels, layout, etc.")
;; Any version of the GPL
(license license:gpl2+)))
+(define-public r-stable
+ (package
+ (name "r-stable")
+ (version "1.1.6")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "stable" version))
+ (sha256
+ (base32
+ "194xsa291v5f0jya1c3aigbclg8cci427ffpb8brxamm6n57hf12"))))
+ (properties `((upstream-name . "stable")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rmutil))
+ (home-page "https://www.commanster.eu/rcode.html")
+ (synopsis
+ "Probability functions and regression models for stable distributions")
+ (description
+ "This package provides density, distribution, quantile and hazard
+functions of a stable variate, as well as generalized regression models for
+the parameters of a stable distribution.")
+ (license license:gpl2+)))
+
(define-public r-statip
(package
(name "r-statip")