aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2019-10-12 13:34:43 -0500
committerAlex Griffin <a@ajgrf.com>2019-10-29 21:06:25 -0500
commit9ad9ec2e6192017ccac59330c0056c370c079603 (patch)
tree58a5880b89f556ac00af3b506eb2a0f26187943b /gnu
parent8476e5857a3fc9eabeeadf21ec7d98bf0b5af197 (diff)
downloadguix-9ad9ec2e6192017ccac59330c0056c370c079603.tar
guix-9ad9ec2e6192017ccac59330c0056c370c079603.tar.gz
gnu: Add ghc-atomic-primops.
* gnu/packages/haskell-xyz.scm (ghc-atomic-primops): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 2977398880..e134641de4 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;; Copyright © 2019 Kyle Meyer <kyle@kyleam.com>
+;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -381,6 +382,28 @@ over threads in Haskell, in which @code{Async a} is a concurrent thread that
will eventually deliver a value of type @code{a}.")
(license license:bsd-3)))
+(define-public ghc-atomic-primops
+ (package
+ (name "ghc-atomic-primops")
+ (version "0.8.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/atomic-primops"
+ "/atomic-primops-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0cyr2x6xqz6s233znrz9rnrfj56m9bmnawwnka0lsqqy1hp8gy37"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-primitive" ,ghc-primitive)))
+ (home-page "https://github.com/rrnewton/haskell-lockfree/wiki")
+ (synopsis "Safe approach to CAS and other atomic ops")
+ (description
+ "GHC 7.4 introduced a new @code{casMutVar} PrimOp which is difficult to
+use safely, because pointer equality is a highly unstable property in Haskell.
+This library provides a safer method based on the concept of @code{Ticket}s.")
+ (license license:bsd-3)))
+
(define-public ghc-atomic-write
(package
(name "ghc-atomic-write")