aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-22 13:28:17 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-23 00:31:20 +0200
commit98a5a1a14d0ef9cb4ed2906fdda42ea3d57a8a13 (patch)
treea6dc484bd2ec2567e471592e0e621d52b081ff35 /gnu
parente7f0f1d567b60b5d8d868af28fdc34556a73d812 (diff)
downloadguix-98a5a1a14d0ef9cb4ed2906fdda42ea3d57a8a13.tar
guix-98a5a1a14d0ef9cb4ed2906fdda42ea3d57a8a13.tar.gz
gnu: Add ghc-vty-unix.
gnu/packages/haskell-xyz.scm (ghc-vty-unix): New variable. Change-Id: Idf8e550a5d7b645d19af177dd65c5956ba3ab478
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 5647cf3c17..f6422dba5c 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -14153,6 +14153,31 @@ one package so you don't have to conditionally depend on them in your cabal
file.")
(license license:bsd-3)))
+(define-public ghc-vty-unix
+ (package
+ (name "ghc-vty-unix")
+ (version "0.2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "vty-unix" version))
+ (sha256
+ (base32 "1hfxc7qw884vlq8qshhyndl3zs10jc2xr6i69vhasjywkvh6gay2"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "vty-unix")))
+ (inputs (list ghc-blaze-builder
+ ghc-vty-6
+ ghc-vector
+ ghc-utf8-string
+ ghc-microlens
+ ghc-microlens-mtl
+ ghc-microlens-th
+ ghc-ansi-terminal))
+ (home-page "https://hackage.haskell.org/package/vty-unix")
+ (synopsis "Unix backend for Vty")
+ (description "This package provides Unix terminal support for Vty.")
+ (license license:bsd-3)))
+
(define-public ghc-wave
(package
(name "ghc-wave")