aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2017-05-25 00:55:22 +0200
committerRoel Janssen <roel@gnu.org>2017-05-25 00:55:22 +0200
commit9619a95ed8bbc400af6536e9619cf9c65a5833eb (patch)
tree57a94eaefea5be87c2fd1c527103d21d8fe77303 /gnu
parent631ced1b5b0dfccf70bdca9947111894ea5a00f7 (diff)
downloadguix-9619a95ed8bbc400af6536e9619cf9c65a5833eb.tar
guix-9619a95ed8bbc400af6536e9619cf9c65a5833eb.tar.gz
gnu: Add emacs-rainbow-mode.
* gnu/packages/emacs.scm (emacs-rainbow-mode): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index a59a4ca698..8c3950d31d 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3248,6 +3248,25 @@ identifiers based on their names. Each identifier gets a color based on a hash
of its name.")
(license license:bsd-2)))
+(define-public emacs-rainbow-mode
+ (package
+ (name "emacs-rainbow-mode")
+ (version "0.12")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://elpa.gnu.org/packages/rainbow-mode-" version ".el"))
+ (sha256
+ (base32
+ "10a7qs7fvw4qi4vxj9n56j26gjk61bl79dgz4md1d26slb2j1c04"))))
+ (build-system emacs-build-system)
+ (home-page "http://elpa.gnu.org/packages/rainbow-mode.html")
+ (synopsis "Colorize color names in buffers")
+ (description
+ "This minor mode sets background color to strings that match color
+names, e.g. #0000ff is displayed in white with a blue background.")
+ (license license:gpl3+)))
+
(define-public emacs-visual-fill-column
(package
(name "emacs-visual-fill-column")