aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-22 13:28:00 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-23 00:31:19 +0200
commit9539293213a5de9070d43ea038b82a540941d186 (patch)
tree0d99189b48d0979616f892a2daaa65c0b62695e2 /gnu
parentf0514b9cac5fe10c75d31f6c90fa3c8160354fd5 (diff)
downloadguix-9539293213a5de9070d43ea038b82a540941d186.tar
guix-9539293213a5de9070d43ea038b82a540941d186.tar.gz
gnu: Add ghc-crypton-x509-store.
* gnu/packages/haskell-crypto.scm (ghc-crypton-x509-store): New variable. Change-Id: Id9e2bd91d99c09fee5bd0054741176108b7376ed
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-crypto.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index bd8007e496..7b06676024 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -679,6 +679,29 @@ abstraction for CPRNGs.")
(description "This package provides generic X509 support for Haskell.")
(license license:bsd-3)))
+(define-public ghc-crypton-x509-store
+ (package
+ (name "ghc-crypton-x509-store")
+ (version "1.6.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "crypton-x509-store" version))
+ (sha256
+ (base32 "0vr5b9cyf9x016wn1g0bryslf5nz8jq2sy8r3llwqfg02apihqiy"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "crypton-x509-store")))
+ (inputs (list ghc-pem ghc-asn1-types ghc-asn1-encoding ghc-crypton
+ ghc-crypton-x509))
+ (native-inputs (list ghc-tasty ghc-tasty-hunit))
+ (home-page "https://github.com/kazu-yamamoto/crypton-certificate")
+ (synopsis "X.509 collection accessing and storing methods")
+ (description
+ "This package provides methods for accessing and storing X.509
+collections of certificates, certificate revocation lists, and exception
+lists.")
+ (license license:bsd-3)))
+
(define-public ghc-cprng-aes
(package
(name "ghc-cprng-aes")