aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2013-12-15 09:03:37 +0100
committerLudovic Courtès <ludo@gnu.org>2013-12-15 22:31:18 +0100
commit94e450812bc9ca5797645d1b256a5dc11a87f51a (patch)
treec368591354078ecedec2f78ad2346f5ef84259bf /gnu
parent9b937137fbe74bf0d7c0ad766531a9fdf00ce62e (diff)
downloadguix-94e450812bc9ca5797645d1b256a5dc11a87f51a.tar
guix-94e450812bc9ca5797645d1b256a5dc11a87f51a.tar.gz
gnu: openssl: Fix cross-compile issues.
* gnu/packages/openssl.scm (openssl): Move perl from inputs to native-inputs. Replace reference to target bash with the native bash or target bash as appropriate. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/openssl.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/openssl.scm b/gnu/packages/openssl.scm
index ca72aa804e..438e76fd71 100644
--- a/gnu/packages/openssl.scm
+++ b/gnu/packages/openssl.scm
@@ -35,7 +35,7 @@
(sha256 (base32
"1gjy6a7d8nszi9wq8jdzx3cffn0nss23h3cw2ywlw4cb9v6v77ia"))))
(build-system gnu-build-system)
- (inputs `(("perl" ,perl)))
+ (native-inputs `(("perl" ,perl)))
(arguments
'(#:parallel-build? #f
#:parallel-tests? #f
@@ -52,8 +52,8 @@
(string-append "--prefix=" out)))))
(alist-cons-before
'patch-source-shebangs 'patch-tests
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((bash (assoc-ref inputs "bash")))
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (let ((bash (assoc-ref (or native-inputs inputs) "bash")))
(substitute* (find-files "test" ".*")
(("/bin/sh")
(string-append bash "/bin/bash"))