aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-01-07 08:42:15 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-01-07 08:42:15 +0200
commit93b3a8b0eeabeca960a178754589c6461b38baf5 (patch)
treed0514815085e9448adca28a41492dcef4570f15f /gnu
parentbfcb7bcb739c6c0cc5c564b5f2bc94e0aa33a556 (diff)
downloadguix-93b3a8b0eeabeca960a178754589c6461b38baf5.tar
guix-93b3a8b0eeabeca960a178754589c6461b38baf5.tar.gz
gnu: flex: Update to 2.6.0.
* gnu/packages/flex.scm (flex): Update to 2.6.0. [source]: Remove flex-bison-tests.patch. * gnu-system.am (dist_patch_DATA): Remove flex-bison-tests.patch. * gnu/packages/patches/flex-bison-tests.patch: Remove it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/flex.scm6
-rw-r--r--gnu/packages/patches/flex-bison-tests.patch24
2 files changed, 3 insertions, 27 deletions
diff --git a/gnu/packages/flex.scm b/gnu/packages/flex.scm
index 7988e930e7..f8d5ccd032 100644
--- a/gnu/packages/flex.scm
+++ b/gnu/packages/flex.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,15 +32,14 @@
(define flex
(package
(name "flex")
- (version "2.5.37")
+ (version "2.6.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/flex/flex-"
version ".tar.bz2"))
(sha256
(base32
- "0ah5mi4j62b85a9rllv1004mzjb5cd0mn4glvz13p88rpx77pahp"))
- (patches (list (search-patch "flex-bison-tests.patch")))))
+ "1sdqx63yadindzafrq1w31ajblf9gl1c301g068s20s7bbpi3ri4"))))
(build-system gnu-build-system)
(inputs
(let ((bison-for-tests
diff --git a/gnu/packages/patches/flex-bison-tests.patch b/gnu/packages/patches/flex-bison-tests.patch
deleted file mode 100644
index 0f372f83bf..0000000000
--- a/gnu/packages/patches/flex-bison-tests.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-The `test-bison-yyl{loc,val}' tests fail with "conflicting types for
-'testparse'" because `YYPARSE_PARAM' is undefined; work around that.
-
---- flex-2.5.37/tests/test-bison-yylloc/main.c 2012-11-22 18:17:01.000000000 +0100
-+++ flex-2.5.37/tests/test-bison-yylloc/main.c 2012-11-22 18:17:07.000000000 +0100
-@@ -21,6 +21,7 @@
- * PURPOSE.
- */
-
-+#define YYPARSE_PARAM scanner
- #include "parser.h"
- #include "scanner.h"
-
-
---- flex-2.5.37/tests/test-bison-yylval/main.c 2012-11-22 18:17:42.000000000 +0100
-+++ flex-2.5.37/tests/test-bison-yylval/main.c 2012-11-22 18:17:49.000000000 +0100
-@@ -21,6 +21,7 @@
- * PURPOSE.
- */
-
-+#define YYPARSE_PARAM scanner
- #include "parser.h"
- #include "scanner.h"
-