aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-07 02:36:18 -0400
committerMark H Weaver <mhw@netris.org>2015-07-09 03:30:27 -0400
commit92f1b4a54c58d57bcc8d52e6970785c2b895c6b9 (patch)
tree4af36c76344697c081199388ce5eab0708a06764 /gnu
parent549381d6db229a440cd48158015c760891bbb238 (diff)
downloadguix-92f1b4a54c58d57bcc8d52e6970785c2b895c6b9.tar
guix-92f1b4a54c58d57bcc8d52e6970785c2b895c6b9.tar.gz
gnu: Add gst-plugins-ugly.
* gnu/packages/gstreamer.scm (gst-plugins-ugly): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gstreamer.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 0f3a0fbdf0..d7296e586b 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -243,6 +243,45 @@ GStreamer multimedia library. This set contains those plug-ins which the
developers consider to have good quality code and correct functionality.")
(license lgpl2.0+)))
+(define-public gst-plugins-ugly
+ (package
+ (name "gst-plugins-ugly")
+ (version "1.4.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://gstreamer.freedesktop.org/src/"
+ name "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0rwhljn3f8mp2pfchzfcx4pvps1546dndw9mr56lz50qyqffimaw"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("gst-plugins-base" ,gst-plugins-base)
+ ("liba52" ,liba52)
+ ("libmad" ,libmad)
+ ("lame" ,lame)
+ ("libcdio" ,libcdio)
+ ("twolame" ,twolame)
+ ("libmpeg2" ,libmpeg2)
+ ("libdvdread" ,libdvdread)
+ ("libx264" ,libx264)
+ ;; TODO:
+ ;; * opencore-amr (for the AMR-NB decoder and encoder and the
+ ;; AMR-WB decoder) <http://sourceforge.net/projects/opencore-amr/>
+ ("orc" ,orc)))
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("pkg-config" ,pkg-config)
+ ("python-wrapper" ,python-wrapper)))
+ (home-page "http://gstreamer.freedesktop.org/")
+ (synopsis
+ "GStreamer plugins from the \"ugly\" set.")
+ (description "GStreamer Ugly Plug-ins. This set contains those plug-ins
+which the developers consider to have good quality code but that might pose
+distribution problems in some jurisdictions, e.g. due to patent threats.")
+ (license lgpl2.0+)))
+
(define-public gst-libav
(package
(name "gst-libav")