aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-21 22:43:59 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 20:46:47 +0100
commit838377c4d7e587e4e70bcdf85ca663bd149f6a06 (patch)
tree5da87c7be834efaf1f2e926b8a724992225ea07a /gnu
parent48f7e826d2a688966ce39019279d3e30ca5018a7 (diff)
downloadguix-838377c4d7e587e4e70bcdf85ca663bd149f6a06.tar
guix-838377c4d7e587e4e70bcdf85ca663bd149f6a06.tar.gz
gnu: Add go-k8s-io-klog.
* gnu/packages/golang-xyz.scm (go-k8s-io-klog): New variable. Change-Id: I5985ef3f9342fb1cc671c3d113cef78785650548
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index a369127c4f..34b2c694cd 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -6709,6 +6709,44 @@ Go.")
values.")
(license license:asl2.0)))
+(define-public go-k8s-io-klog
+ (package
+ (name "go-k8s-io-klog")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kubernetes/klog")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1cgannfmldcrcksb2wqdn2b5qabqyxl9r25w9y4qbljw24hhnlvn"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "k8s.io/klog"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (substitute* (find-files "." "\\_test.go$")
+ ;; Disable test requiring write access to creat test files.
+ (("TestRollover") "OffTestRollover"))))))))
+ (propagated-inputs
+ (list go-github-com-go-logr-logr))
+ (home-page "https://github.com/kubernetes/klog")
+ (synopsis "Leveled execution logs for Go")
+ (description
+ "Package klog implements logging analogous to the Google-internal C++
+INFO/ERROR/V setup. It provides functions @code{Info}, @code{Warning},
+@code{Error}, @code{Fatal}, plus formatting variants such as @code{Infof}. It
+also provides V-style logging controlled by the @code{-v} and
+@code{-vmodule=file=2} flags. It's a is a permanent fork of
+@code{https://github.com/golang/glog}.")
+ (license license:asl2.0)))
+
(define-public go-mvdan-cc-editorconfig
(package
(name "go-mvdan-cc-editorconfig")