aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-10-19 22:52:30 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-30 19:32:15 +0000
commit81dff32a6f3e65f98bfe9faabeef88dc5359a8dc (patch)
tree6f3ef887e598f7a7405f9c9ee9ad4f04c6bfae2b /gnu
parent2263c490a23184b75d47e47fe8e05c8393a05785 (diff)
downloadguix-81dff32a6f3e65f98bfe9faabeef88dc5359a8dc.tar
guix-81dff32a6f3e65f98bfe9faabeef88dc5359a8dc.tar.gz
gnu: python-photutils: Update to 2.0.1.
* gnu/packages/astronomy.scm (python-photutils): Update to 2.0.1. [arguments]<#:phases>: Add 'relax-requirements phase. [propagated-inputs]: Remove python-scikit-learn; add python-regions. [native-inputs]: Add python-setuptools. Change-Id: If8533af300fdc695e9415d80806c5d88620921cb
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 0cc87145b2..4520bd2443 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3736,22 +3736,25 @@ can be described by @acronym{WCS, World Coordinate System} translations.")
(define-public python-photutils
(package
(name "python-photutils")
- ;; PyPI version for source archive is missing minor 0, See
- ;; <https://github.com/astropy/photutils/issues/1727>
- (version "1.13.0")
+ (version "2.0.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "photutils" version))
(sha256
- (base32 "1lhpcxh2adknzlmrddqd712yzpwdlqlw9jn49ajj4kz5z7822dns"))))
+ (base32 "1mcsp5bsg3i6w3v9gf7vhkyhlxsn57hgbs0b94p5c4hcv9fa4y3g"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags
- #~(list "-n" "auto")
+ #~(list "--numprocesses" "auto")
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "pyproject.toml"
+ ;; numpy>=1.24
+ ((">=1.24") ">=1.23"))))
;; setup.py was removed in 36c3231ce5b80ad470fa78be2e96df859d2daf41
;; for some unknown reason, which caused the package to fail to
;; build. It is being recreated based on that commit.
@@ -3781,8 +3784,8 @@ setup(ext_modules=get_extensions())")))))
python-matplotlib
python-numpy
python-rasterio
+ python-regions
python-scikit-image
- python-scikit-learn
python-scipy
python-shapely
python-tqdm))
@@ -3791,6 +3794,7 @@ setup(ext_modules=get_extensions())")))))
python-extension-helpers
python-pytest-astropy
python-pytest-xdist
+ python-setuptools
python-setuptools-scm))
(home-page "https://github.com/astropy/photutils")
(synopsis "Source detection and photometry")