aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-06 21:43:33 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-06 21:43:33 +0100
commit8035819f4c93e1be4a4b7d6d015362461a00865c (patch)
tree0bd666e5203506efa1c352ac542adb6b1340ee35 /gnu
parentd56df35a259dd1faea7780f4ceff84a9c96c699b (diff)
downloadguix-8035819f4c93e1be4a4b7d6d015362461a00865c.tar
guix-8035819f4c93e1be4a4b7d6d015362461a00865c.tar.gz
gnu: r-org-mm-eg-db: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-org-mm-eg-db): Move from here... * gnu/packages/bioconductor.scm (r-org-mm-eg-db): ...to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm26
-rw-r--r--gnu/packages/bioinformatics.scm26
2 files changed, 26 insertions, 26 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7079092335..1d36910637 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -464,6 +464,32 @@ based on mapping using Entrez Gene identifiers.")
on mapping using Entrez Gene identifiers.")
(license license:artistic2.0)))
+(define-public r-org-mm-eg-db
+ (package
+ (name "r-org-mm-eg-db")
+ (version "3.7.0")
+ (source (origin
+ (method url-fetch)
+ ;; We cannot use bioconductor-uri here because this tarball is
+ ;; located under "data/annotation/" instead of "bioc/".
+ (uri (string-append "https://www.bioconductor.org/packages/"
+ "release/data/annotation/src/contrib/"
+ "org.Mm.eg.db_" version ".tar.gz"))
+ (sha256
+ (base32
+ "1i3nvrd3wjigf1rmgxq1p5xxc3p8v02h5gwi62s30rkrsyjjfjxx"))))
+ (properties
+ `((upstream-name . "org.Mm.eg.db")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)))
+ (home-page "https://www.bioconductor.org/packages/org.Mm.eg.db/")
+ (synopsis "Genome wide annotation for Mouse")
+ (description
+ "This package provides mappings from Entrez gene identifiers to various
+annotations for the genome of the model mouse Mus musculus.")
+ (license license:artistic2.0)))
+
(define-public r-bsgenome-hsapiens-ucsc-hg19
(package
(name "r-bsgenome-hsapiens-ucsc-hg19")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b06c8cf1fd..c0e4628a64 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7980,32 +7980,6 @@ genomation package. Included are Chip Seq, Methylation and Cage data,
downloaded from Encode.")
(license license:gpl3+)))
-(define-public r-org-mm-eg-db
- (package
- (name "r-org-mm-eg-db")
- (version "3.7.0")
- (source (origin
- (method url-fetch)
- ;; We cannot use bioconductor-uri here because this tarball is
- ;; located under "data/annotation/" instead of "bioc/".
- (uri (string-append "https://www.bioconductor.org/packages/"
- "release/data/annotation/src/contrib/"
- "org.Mm.eg.db_" version ".tar.gz"))
- (sha256
- (base32
- "1i3nvrd3wjigf1rmgxq1p5xxc3p8v02h5gwi62s30rkrsyjjfjxx"))))
- (properties
- `((upstream-name . "org.Mm.eg.db")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-annotationdbi" ,r-annotationdbi)))
- (home-page "https://www.bioconductor.org/packages/org.Mm.eg.db/")
- (synopsis "Genome wide annotation for Mouse")
- (description
- "This package provides mappings from Entrez gene identifiers to various
-annotations for the genome of the model mouse Mus musculus.")
- (license license:artistic2.0)))
-
(define-public r-seqlogo
(package
(name "r-seqlogo")