aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-09-12 13:26:57 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-09-12 14:29:13 +0800
commit7bd8e290b57b611027a1006aa8aa2306a27f84d7 (patch)
tree598914100488d0f97bfa434edf097a567c6a6378 /gnu
parentcd9ad4efe89f63d45600ea4868a0d385b1b1ebee (diff)
downloadguix-7bd8e290b57b611027a1006aa8aa2306a27f84d7.tar
guix-7bd8e290b57b611027a1006aa8aa2306a27f84d7.tar.gz
gnu: coq-bignums: Update style.
* gnu/packages/coq.scm (coq-bignums)[arguments]: Use G-expression. Change-Id: Ib34ec1d543775f96777dfe31990b6526f589bee6
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/coq.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 4b26c634d8..ffd8560a48 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2022 Garek Dyszel <garekdyszel@disroot.org>
;;; Copyright © 2024 Foundation Devices, Inc. <hello@foundation.xyz>
+;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -449,8 +450,8 @@ theorems between the two libraries.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/coq/bignums")
- (commit (string-append "v" version))))
+ (url "https://github.com/coq/bignums")
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
@@ -461,15 +462,15 @@ theorems between the two libraries.")
(inputs
(list camlp5))
(arguments
- `(#:tests? #f ; No test target.
- #:make-flags
- (list (string-append "COQLIBINSTALL=" (assoc-ref %outputs "out")
- "/lib/coq/user-contrib")
- (string-append "COQPLUGININSTALL=" (assoc-ref %outputs "out")
- "/lib/ocaml/site-lib/"))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure))))
+ (list #:tests? #f ; No test target.
+ #:make-flags
+ #~(list (string-append "COQLIBINSTALL=" #$output
+ "/lib/coq/user-contrib")
+ (string-append "COQPLUGININSTALL=" #$output
+ "/lib/ocaml/site-lib/"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
(home-page "https://github.com/coq/bignums")
(synopsis "Coq library for arbitrary large numbers")
(description "Bignums is a coq library of arbitrary large numbers. It